Missing text for some labels when default language is italian

Vote:
 

Hello

Setting italian as main language of our website, we have a problem with some labels into the cms area.

For example in the right sidebar of media/blocks, the titles "Blocks" / "Media" are not visible. We see something like [Missing text '/episerver/cms/components/sharedblocks/title' for 'Italian'].

Same behaviour in the left sidebar with the menu tree, titles are not visible.

Many other labels are correctly in english, so it seems like some labels are missing.

The problem is not present if I set english as default language of that website

#117220
Feb 13, 2015 17:46
Vote:
 

Hi Claudio,

I don't think the UI supports Italian out of the box, which means the translation you are using comes from a third party (or whoever designed your website).

Is this an upgrade site?

/T

#117231
Feb 13, 2015 23:38
Vote:
 

Hi Claudio!

As Toni stated, there is no official support for Italian at the moment but fortunately this is actually being added at the moment so we will release official support for this soon, probably within a few weeks.

#117249
Feb 16, 2015 8:29
Vote:
 

well I am working on that site, it's a new customer's website under construction.

And I didn't ask for a translation in italian....  english is fine. But why some labels are missing, even if in english?

#117250
Edited, Feb 16, 2015 8:32
Vote:
 

Hi again!

If you are getting Italian translations, then you must have done something to your site, for instance adding Italian translation or changes the UI culture in configuration. There is a configuration section where you should be able to configure fall back logic for translations. Make sure that you have fallback to english enabled here:

<localization fallbackBehavior="Echo, MissingMessage, FallbackCulture" fallbackCulture="en">

#117260
Feb 16, 2015 10:52
Vote:
 

hello Linus

I have that row in my web.config, inside the <episerver.framework> settings

#117902
Feb 24, 2015 8:10
Vote:
 

Hi Claudio!

It's good that you have the fallback configuration. However, you still need to find why the user get's Italian, for instance by setting Italian as the system UI language or a personal user interface section. Check the globalization section in web.config to see the default UI language:

<globalization culture="en-US" uiCulture="en"

Also, it's possible for the user to select another UI language in the "My Settings" dialog.

Also, it could be good to know that we released EPiServer CMS 8 yesterday that now has native UI support for Italian.

#117908
Feb 24, 2015 8:39
Vote:
 

thank you Linus, I saw about the new episerver version, so I think I will try it during this week.

I'll let you know if it's fine for italian

#117927
Feb 24, 2015 11:45
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.