Episerver template for visual studio 2010

Vote:
 

I have installed Episerver 7 on my pc. When I open my Visual studio 2010, I do not see any EpiServer template to create Episerver website. when I search for EpiServer in Extension Manager, I could only see 'Language files extension for Episerver' and 'PageUsageType'.

when I search for visual studio extension, I got the following url which is compatible only with Visual studio 2012/2013.

How do I get the episerver template on visual studio 2010 to work with?

Other thing is, when I pulled in Episerver project and tried to run, it is complaining about missing Episerver. CMO

could anyone please help.

#112960
Nov 09, 2014 20:12
Vote:
 

There are no support for visual studio 2010 no more.

download visual studio 2013 express and then download the extension from here:

http://world.episerver.com/PageFiles/138782/EPiServerVsExtensionForExpressSKU.zip

#112961
Nov 09, 2014 20:52
Vote:
 

The projects was built long back on visual studio 2010. why do I need visual studio 2013 express for it?

I need to work on changes(adding three new templates) to my company client's project which was built on Visual Studio 2010 using Episerver CMS 7.0.586.1.

I have installed visual studio 2010 and EPiServer 7.0.586.1.

How do I work on it now as I do not see any EPiServer templates to add and is also complaining about missing EPiServer.CMO

#112962
Nov 09, 2014 21:38
Vote:
 

Hi!

You do not have to have the Visual Studio extensions to work with a EPiServer project. Just load the project and create the new items manually, just as you would for any other web project.

Regards
Linus

#112967
Nov 10, 2014 7:55
Vote:
 

Support for Visual Studio was removed in version 7.7.0.14, read more here:

https://visualstudiogallery.msdn.microsoft.com/4ad95160-e72f-4355-b53e-0994d2958d3e

As Linus say, you do not need the templates, there are only there as guidence or help, just look at how these other files are done, and do like that.

Have you installed CMO on your computer? (For 7.0 it needs to be installed)

#112968
Nov 10, 2014 8:54
Vote:
 

I am unable to find the dll Episerver.cmo.cms. When I run the project, it's complaining about 

Could not load file or assembly 'EPiServer.Cmo.Cms' or one of its dependencies

#112990
Nov 10, 2014 10:23
Vote:
 

I could only find EPiServer CMO for 7.5. As I installed EPiServerCMS7.0.586.1, I would need EPiServer CMO for 7 I think. Please help

I have looked at the following url and then worked on deployment centrer and chosen the option to create new database

http://world.episerver.com/Documentation/Items/Installation-Instructions/EPiServer-CMO/EPiServer-7-CMO/Installation-Instructions---EPiServer-7-CMO/#install_website

Now the issue is with Unable to find a module by assembly 'EPiServer.Social'

Where to find the assembly 'EPiServer.Social' for EPiServer 7?

#112991
Edited, Nov 10, 2014 10:28
Vote:
 

You can find it here:

http://world.episerver.com/Download/Items/EPiServer-CMO/EPiServer-7-CMO1/

#112994
Nov 10, 2014 11:46
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.