7.0 to 7.16.0

Vote:
 

I have EPiServer 7.0.586.1 installed on my PC. Now I have to work on a project which is built on 7.16.0. I am thinking to upgrade by following the instructions below.

http://world.episerver.com/Documentation/Items/Installation-Instructions/EPiServer-CMS/Version-7/Installation-Instructions---EPiServer-7-CMS/Installation-Instructions---EPiServer-7-1-CMS/

Will this affect the other site which are running on 7.0.586.1? 

Is Visual Studio 2010 fully compatible with 7.16.0 or should I need to install Visual Studio 2012?

#113186
Nov 14, 2014 13:13
Vote:
 

For 7.16 you do not need to install anything so it will work perfectly side by side (if you not using CMO)

#113191
Nov 14, 2014 13:51
Vote:
 

I have installed CMO for other projects on 7.0.586.1. What do I need to do if I have to work on 7.16.0 now?

What version of visual studio would be ok with 7.16.0, VS 2010/2012?

In general, Could we able to know what version of visual studio used on an episerver site?

#113193
Edited, Nov 14, 2014 14:03
Vote:
 

If you do not need it for the project on 7.16 there is no problem.

Hopefully the one that has created the project has added all the needed nuget-packages, in case of that, all you need to do is get the latest version of the source code and press F5.

You might have to get a version of the database if you work with local databases

#113194
Nov 14, 2014 14:07
Vote:
 

Thank you for that.

In general, is Version 7.16 fully compatible with Visual Studio 2012? or do I need to install Visual Studio 2010?

#113195
Nov 14, 2014 14:26
Vote:
 

It works best with 2012 or 2013 (have not tried it in 2015)

Please mark it at answear if you think I have answered your question

#113196
Nov 14, 2014 14:32
Vote:
 

I want to clarify a bit as from CMS.Core 7.14, we require .NET 4.5 so VS 2012/2013 is needed (and fully supported)

/Q

#113200
Nov 14, 2014 15:01
Vote:
 

True Quan, I forgot to mention that :-)

#113201
Nov 14, 2014 15:07
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.