Wrong UICulture when previewing web sites in OPE

Vote:
 

I have a web site built in WebForms that are upgraded from EPiServer 6 to EPiServer 7 I quite often use the Translate web control and the Translate methods without specifying any languages to let EPiServer decide which translation to use.

When browing in View mode (outside EPiServer UI) everything seems ok, I can switch language by browsing with different language prefix in the url exactly like everything is supposed to behave.

But when I'm previewing a page in OPE mode, the Translate methods does not seem to follow the same language as I wish to see the content.

I've found out that while in OPE, the CultureInfo.CurrentUICulture seems to be read from the uiCulture attribute on the Globalization section in web.config.

It does not matter which LanguageBranch or MasterLanguage my CurrentPage have, which SiteHost language is set in EPiServerFramework.config or which language i select in the Sites tab on the Navigation Gadget.

I can easily replicate this in Alloy Templates

1: Adding following to /Resources/LanguageFiles/Views.xml:

<language name="Swedish"
id="sv">
<mainnavigation>
<search>Sök</search>
</mainnavigation>
</language>

2: Make sure that Swedish is activated in Admin mode

3: Make sure Swedish is an Available Language for your web site in Language Settings

4: Translate your start page to Swedish and browse to your Swedish translation on http://localhost:17000/sv/

5: Make sure that the watermark/placeholder on the quicksearch text field is "Sök".

6: Browse to english version on http://localhost:17000/ and make sure that the watermark/placeholder is still "Search"

7: Log on to EPiServer UI and preview both the swedish and english version. Both languages have the watermark/placeholder "Search" in the quicksearch field.

8: Go to web.config and change the uiCulture to uiCulture="sv" in the globalization section.

9: Go back to EPiServer UI and preview both the swedish and english version. Both languages have the watermark/placeholder "Sök" in the quicksearch field.

 

#71948
Jun 02, 2013 16:58
Vote:
 

Yes, this is known bug #95725. Thank you for reporting!

#71954
Jun 03, 2013 9:59
Vote:
 

Thanks, Speaking of bugs where can I find the bug list for EPiServer 7?

http://world.episerver.com/Support/Bug-List/ only contains up to EPiServer 6 R2

#71965
Jun 03, 2013 11:46
Vote:
 

Unfortunatelly, the bug list for EPiServer 7 is not available on world right now. You can find the list of fixed bugs in Patch 1, Patch 2 and Patch 3.

#71976
Jun 03, 2013 14:45
Vote:
 

Sorry to revive this old post, but for those trying to find bug #95725: It seems that this issue was not fixed until Episerver 7.5, as bug number 91856.

#152021
Aug 12, 2016 14:06
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.