Edit Mode in English when English is not a site language

Vote:
 

The site in question is available in three Scandinavian languages.

For all editors the Edit Mode is to be used only in English. To get English as the default system language we have it as culture and uiCulture in web.config/globalization.

Seems like when Edit Mode is in English and when English is not a site language makes template texts from LocalizationService.Current inside Edit Mode preview render empty strings. Inspecting LocalizationService.Current when debugging shows English as the language in play.

Are we doing something wrong in our templates/globalization-in-web.config or is this by design? If by design, is switching culture back and forth somehow recommended?

#71724
May 27, 2013 15:01
Vote:
 

Hi!

I reported this bug some months ago but appearantly it has not been fixed yet: Bug #91856: UI language does not follow content language in EPiServer 7 when editing. I have updated the priority for the bug so that it's fixed for the next release.

If you are curious about the reason it's because the new route used to load the preview is different from the public route and considered to be part of the UI. And for things inside the UI, the UI language is determined by the users settings.

#71736
May 27, 2013 18:38
Vote:
 

Thanks Linus! Good to know.

#71744
May 28, 2013 10:28
Vote:
 

Hi,

Is there any progress with that bug? It is quite annoying for our customers. They would like to see also translations in correct language, not always in English.

#72877
Jul 02, 2013 10:55
Vote:
 

Unfortunately, this is still an active bug.

#72918
Jul 03, 2013 7:42
Vote:
 

And here it is, as we thought, customer already started complaining that texts in CMS are not translated (they are in English), are there any plans to fix it or some existing workaround?

#73865
Aug 13, 2013 12:20
Vote:
 

This bug should be fixed in the EPiServer 7.5 release.

#80404
Jan 22, 2014 13:27
Vote:
 

Sorry to bump this, but is this fixed ???

Because in the latest EPiServer 8.6.0 i'm still having this problem. Using LocalizationService.Current in Edit mode, i always get the EN culture even though my site is in NL culture.

#121905
May 20, 2015 11:47
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.