CMS 7.1 patch breaks custom TinyMCE plugins

Vote:
 

CMS 7.1 patch breaks custom TinyMCE plugins; the TinyMCE editor will not be rendered if you have custom plugins. The plugin worked fine with CMS 6 and CMS 7.0, therefore the cause of breakdown is in 7.1 patch.

 

 

 

#69964
Apr 10, 2013 10:48
Vote:
 

The conflict was with a TinyMCEPluginNonVisual plugin. After removing it, the editor worked once again.

[TinyMCEPluginNonVisual(
    AlwaysEnabled = true, 
    EditorInitConfigurationOptions = "{ extended_valid_elements: 'iframe[src|frameborder=0|alt|title|width|height|align|name]' }")]
public class ExtendedValidElements
{

}
#69966
Apr 10, 2013 11:01
Vote:
 

I think you need an empty js file in the plugin folder for even server side plugins. Tinymce fails to overcome script not found issues on Firefox and Chrome.

#69969
Apr 10, 2013 11:14
Vote:
 

I have the same issue with TinyMCE Visual Plugin, I added empty js file but it doesn't work .Any guide ?

#132718
Aug 18, 2015 9:01
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.