EPIServer 7.5 XCOPY deployment

Vote:
 

Release notes(http://world.episerver.com/Blogs/Ben-McKernan/Dates/2013/11/Restricting-the-allowed-types-in-a-content-area/) state that there are:

  • No references to Program Files

I've just installed Commerce 7.5 sample site and found a couple of them (EPiServerFramework.config):

<virtualPathProviders>
<clear />
<add name="ProtectedAddons" virtualPath="~/episerver/" physicalPath="[appDataPath]\Modules" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />
<add name="EPiServerCommon" virtualPath="~/EPiServerCommon/" physicalPath="C:\Program Files (x86)\EPiServer\CommonFramework\7.5.394.2\Application\EPiServerCommon" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />
<add name="EPiServerCommerce" virtualPath="~/episerver//Commerce" physicalPath="C:\Program Files (x86)\EPiServer\CMS\7.5.394.2\Install\Modules\EPiServer Commerce 7.5.394.2\Application" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />
</virtualPathProviders>

Is that "junk/obsolete" reference or they are required?

#78804
Dec 03, 2013 19:09
Vote:
 

Hi!

The release notes in http://world.episerver.com/Documentation/Items/Release-Notes/Release-notes---EPiServer-75/ could perhaps be more clearly separated. XCOPY deployment is only supported out of the box for the episerver platform/framework and as a consequence by CMS because it does not add any more dependencies preventing it. Commerce however still has dependencies that prevent XCOPY deployment out of the box.

To remove the references to program files I don't think that much should be needed (copy the files to a subfolder in the [appDataPath] and reference them from there instead), but I don't know if that is enough to make Commerce XCOPY deployable. XCOPY support for commerce hasn't been in the plan for this release.

I'm sorry for the unclear documentation on this and any inconveniences this might have caused.

#78846
Dec 04, 2013 11:27
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.