NuGet Package Squishit.Less breaks EPi 7


Does anyone had the problem when you install Squishit.Less from nuget in your solution and after that breaks the site? Every page is white blank. When I remove the package it works again. Hmm....

Nov 12, 2013 15:00

Just installed it without any problems on an existing site. Are you getting 404 or 200 responses back from the server? 


Nov 12, 2013 15:21

I tried a fresh install of EPi 7 using the Visual Studio extension tonight. Everything works great until I run "install-package squishit.less" in NuGet. The following files are added to the project:

  • SquishIt (≥ 0.9.3)
  • YUICompressor.NET (≥
  • AjaxMin (≥ 4.48.4489.28432)
  • dotless (≥
  • WebActivator (≥ 1.4)
  • Microsoft.Web.Infrastructure (≥


In web.config this is added:


<section name="dotless" type="dotless.Core.configuration.DotlessConfigurationSectionHandler, dotless.Core" />

<add name="dotless" path="*.less" verb="GET" type="dotless.Core.LessCssHttpHandler,dotless.Core" resourceType="File" preCondition="" />

<dotless minifyCss="false" cache="true" web="false" />


I have set up my site host to be http://epiforms/ on the IIS. When I browse to the adress I get a blank white page and the response is 500 Internal Server Error (checked with Google Chrome Development toolkit).


Any idea?

Edited, Nov 12, 2013 21:28

If I turn on logging I get the following:

2013-11-12 21:38:56,533 [94] ERROR SearchSettings: Update batch could not be sent to service uri 'http://epiforms/IndexingService/IndexingService.svc/update/?accesskey=local'. Message: 'The remote server returned an error: (500) Internal Server Error.   at System.Net.HttpWebRequest.GetResponse()

   at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action`1 responseHandler)

   at EPiServer.Search.RequestHandler.SendRequest(SyndicationFeed feed, String namedIndexingService, Collection`1 ids)'

2013-11-12 21:38:56,534 [94] ERROR SearchSettings: Send batch for named index 'serviceName' failed. Items are left in queue.

Nov 12, 2013 21:40
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.