Built-in Visitor Group - Geographic Location not working for Australia

Vote:
 

I set up two vistor groups - AU Region and HK Region.

In my wysiwyg editor, I add two different content in the different groups, I am currently living in Australia, so I first connect to HK VPN and visit the site, the HK region displays correctly content, however if I disconnect the VPN and browse the site, it display nothing. 

I tried following steps to fix the issue, but no luck

1. Download the latest geolite.dat file from maxmind site and overwrite the current one from geolocation folder under episerver cms dir

2. Use online service to detect my current IP location, it shows my location is in Australia.

3. In the HK Region, I set the fallback region to AU Region, it still doesn't work

 

I am so frustrated with this issue. 

 

Can anyone show me how to make it working?

 

p.s. The site is running on EPiServer 7.0 without any patch.

#77387
Nov 18, 2013 12:40
Vote:
 

Any EPiServer support team can take a look of this issue? 

#77411
Nov 19, 2013 0:17
Vote:
 

If you want to have support to look at an issue, then just open a source case. Support might look at the forums from time to time but you can't expect an action by just adding a forum thread.

#77433
Nov 19, 2013 10:50
Vote:
 

Geolocation works by passing the IP address from your browser through to the server (where your EPiServer instance is hosted). The IP address is then checked against the geolit.dat database for a match. I'm pretty certain that IP address values will be the key to solving this.

  1. Is this problem happening on your local development environment or a production server?
  2. If its on your local machine have you tried something like this (http://www.david-tec.com/2011/06/Using-the-IIS-rewrite-module-to-test-EPiServer-geo-IP-look-up-personalisation/)
  3. If its on production, have you tried logging the IP address that the server receives in each case (HK and AUS) (IIS should allow you do do this - the IP is passed in the request headers)
#77437
Edited, Nov 19, 2013 13:36
Vote:
 

Hi Mark

Thanks for your suggestion and qucik reply.

My test is done through our staging server which is hosted in Australia. I will ask our administrator to help me check the incoming ip address tomorrow as I can't login to that box.

The reason I think it is a bug of episerver because HK vistor group works fine as I mentioned eariler, since I switched to a HK proxy server in the browser and open the staging site, I can see the HK content, however if I turn off the proxy, I suppose to see AUS content, surpisingly both visitor group contents are disappeared. 

 

There is another issue I addressed in my original thread, I am not too sure it's the episerver bug or I didn't use it properbly. 

As I mentioned in the first thread, rather than spending too much time reflector the code to figure out what's going wrong, I tried to use the fallback feature to make my work done quickly. I set the fallback personalization group within HK vistor group, the fallback value is set to the AUS visitor group. Unfortunately, it didn't work either.

#77446
Nov 19, 2013 15:38
Vote:
 

Hi Linus

 

Thanks for your suggestion, I tried last time, however it took me a week to get the first response back, I am afraid I can't be that patient this time.

I put my question here is expecting to get help from both community and episerver team, I think it will be much faster than open the case, and also if the problem can be resolved here, it will help other community members isn't it?

#77447
Nov 19, 2013 15:50
Vote:
 

No problem,

 

Here's my guess. It's network configuration, when looking at your internal staging server, your machine is passing through an internal IP address which isn't found in the geolite dtabase (as its internal) so you never match in the AU group. When you are on VPN you are routed externally and so the correct HK IP address is passed.

#77448
Nov 19, 2013 16:23
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.