OnPage Editing Not Working?

Vote:
 

I'm able to get my MVC Razor project going. When I was doing my initial Hello World project, I was able to do some onpage editing on my start page. For whatever reason, I can't seem to edit on the page with any new pages. The light blue box does not show up nor does the sidebar with TinyMCE.I can only edit in forms editing mode. Is there something I have to do to a View or my Layout page to make this happen? This is a feature my content authors are going to need.

I've created my page types using the Episerver extentions. I have one type called StartPage with the default MainBody enabled.



#63979
Dec 06, 2012 0:50
Vote:
 

Hi Corbin,

How do you go about rendering the property?

#63980
Dec 06, 2012 8:57
Vote:
 

I'd turn on firebug and see if there is any 500 error in "network" tab and then browser to that url. I'm been in the same situation and it was that path to editor style was wrong.

#63982
Dec 06, 2012 10:10
Vote:
 

Peter, I simply had

<div>

    @Model.MainBody

</div>

 Your reply made me go back to the @Html.PropertyFor(m => m.MainBody) and that was the trick. VS was showing a warning so I thought there was going to be an issue with it. Guess I was wrong :-).

I did not see any 500 errors in Firebug.

#64001
Edited, Dec 06, 2012 16:05
Vote:
 

try

@Html.PropertyFor(m=>m.MainBody)

#64002
Dec 06, 2012 16:09
Vote:
 

Thanks Ruwen for answering this. What PropertyFor does is making a call to DisplayFor with the property selected. But before that, we will make sure to set attributes in edit mode to make sure we get on page edit. If you just rendering it with @Model.MainBody, we have no chanse to do anything, becouse nothing in EPiServer will be called.

#64018
Dec 07, 2012 10:51
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.