Error - Can't install CMO module

dga
Member since: 2012
 

Hi Folk!

When I try to install the CMO module I get following error:

"Error - You cannot call a method on a null-valued expression."

Installation started
EPiServer CMS version is 7.0.586.1
Wizard created
User input gathered
Get-Content : Cannot find path 'C:\Program Files (x86)\EPiServer\Shared\Service
s\Thumbnail Service\IECaptSvc.exe.config' because it does not exist.
At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Install\Modules\CMO7.0.518.1\
Install EPiServer CMO.ps1:290 char:24
+ $content = Get-Content <<<< -Path $serviceConfigurationFilePath
+ CategoryInfo : ObjectNotFound: (C:\Program File...tSvc.exe.confi
g:String) [Get-Content], ItemNotFoundException
+ FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetCon
tentCommand

An unhandled error has occured:
You cannot call a method on a null-valued expression.
When executing

At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Install\Modules\CMO7.0.518.1\
Install EPiServer CMO.ps1:292 char:31
+ $node = $xml.SelectSingleNode <<<< ("configuration/appSettings/add[@key='sec
retkey']")

False
=
Get-EPiIsBulkInstalling
An error has occured and the transaction will be rolled back
Rolledback
Installation failed

At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Install\Modules\CMO7.0.518.1\Install EPiServer CMO.ps1:292 char:31
+ $node = $xml.SelectSingleNode <<<< ("configuration/appSettings/add[@key='secretkey']")
System.Management.Automation.ParentContainsErrorRecordException: You cannot call a method on a null-valued expression.


How can I fix that? 

Thank you in advance for your help!

Cheers

Daniel

 

#64284 Dec 17, 2012 11:04
  • Dmytro Duk
    Member since: 2008
     

    Do you have Thumbnail service installed in directory C:\Program Files (x86)\EPiServer\Shared\Service
    s\Thumbnail Service\? Do you have any files in this folder?

    Can you see CMO Thumbnail service in windows services list?

    It looks like it is "installed" as windows service in the system, but at least configuration file is missed.

    #64290 Dec 17, 2012 12:19
  • Sergii Vorushylo
    Member since: 2008
     

    In order to fix it you can copy a config file from C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Install\Modules\CMO7.0.518.1\Thumbnail Service\IECaptSvc.exe.config to the location, where you thumnail service is installed, usually it is here C:\Program Files (x86)\EPiServer\Shared\Services\Thumbnail Service\. Then run installation one more time. 

    If you are not sure where your Thumbnail Service is installed, please open the Services list and find a service named "EPiServer CMO Thumbnail Service", then check its "Path to executable" property.

    #64299 Dec 17, 2012 13:41