[BUG?] Missing text '/some/translation' for 'English' in OnPage Edit mode

Vote:
 

I have a website with several languages (nl-NL, en-UK etc but NO en). No fallback languages have been set. Replacement languages have been set but not for nl-NL.

The translation (lang) files work fine when viewing the website in browser. But, when editting the page in the cms like so:

http://local.mysitehere.nl/admin/modules/CMS/Home?language=nl-NL#context=epi.cms.contentdata:///10

I get the missing text for English message for all translatable items.

 

#63667
Nov 26, 2012 10:22
Vote:
 

Hi Dick!

What exactly is it that is not working? Are the translations in the preview/editing-iframe incorrect while in the edit view? Or are there texts in the UI that are incorrect when you are you are editing a specific language? Could you post a screens shot perhaps?

#63668
Nov 26, 2012 11:05
Vote:
 

There are translations in the preview/editing-frame missing because it is looking for them in English. I am not using English so of course the texts are missing. The question remains: why would it be searching in English?

http://i50.tinypic.com/21kjq11.jpg

#63669
Edited, Nov 26, 2012 11:13
Vote:
 

Hi!

I debugged it and it seems to be a bug. We are using a different URL to route to the page when editing it since you might actually change the friendly URL while editing. Unfortunately, this URL is considered to be a part of the user interface which has different rules to set the UI culture, for instance using the settings from the current profile. I have created the following bug for this:

Bug #91856: UI language does not follow content language in EPiServer 7 when editing
 
Regards
Linus Ekström
EPiServer Development Team
#63670
Edited, Nov 26, 2012 11:44
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.