Insight/Profile Store Installation Issue

Vote:
 

I have followed the setup guide for insight and the profile store but I'm getting a 

Unable to find a module by assembly 'EPiServer.Insight.UI, Version=1.5.0.0, Culture=neutral, PublicKeyToken=8fe83dea738b45b7'
Parameter name: moduleAssembly

When trying to run the site the bindings all look correct, is there something missing from the installation in the web.config?

#195636
Aug 02, 2018 11:45
Vote:
 

Hi Scott,

Could you please include the module.config under modules/protected/EPiServer.Insight.UI into your project?

And adding the <add name="EPiServer.Insight.UI" /> under web.config/ <episerver.shell>/<protectedModules ...> also?

This issue will be fixed in the 1.6 version.

#195656
Aug 03, 2018 3:47
Vote:
 

Thanks, I had a module.config.template in the modules/protected/EPiServer.Insight.UI folder so I renamed that removing the .template.

Also I had to add assembly rather than name in the protected modules

          <add assembly="EPiServer.Insight.UI" />

Although this got Episerver to load without error I got a massive yellow screen of death when trying to load the Insight UI

David Knipe suggest downgrading to 1.4 Insight.UI which although had the same error in the solution worked after starting from scratch with just 1.4.

Thanks for the help

#195660
Aug 03, 2018 9:40
Vote:
 

This is a bug and it is fixed in the next version 1.6.0 that is being verified by QAs right now.

https://world.episerver.com/documentation/Release-Notes/ReleaseNote/?releaseNoteId=PROF-2622

#195673
Aug 03, 2018 11:45
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.