Submit button on forms loses classes?

Vote:
 

Hey all,

I've just upgraded our Forms package and I'm actually seeing that NO form classes are being applied. I noticed this when we were doing our testing for an upgrade of the nuget packages, so I isolated to just upgrade with the Episerver.Forms nuget package, and it looks like it's removed the class all together... Not to sure if anyone else has experienced this?

Anyone able to provide some clarity around this at all?

Kind regards,

Guy

#224417
Jun 19, 2020 7:12
Vote:
 

What version did you upgrade from, and to?

Are you talking about CSS classes?

#224422
Jun 19, 2020 10:50
Vote:
 

Hi there Thomas,

Apologies for the late response. We upgraded forms package from 4.25.0 to 4.29.0 using the nuget packages. I've taken a screen shot of the classes that I've noticed dissapear. Unless these are custom properties that I've completely misunderstood that we've implemented... But I can't seem to see anywhere in our code base of reference.

If you can let us know any other details, that'd be great.

Kind regards,

Guy

#224483
Edited, Jun 21, 2020 22:47
Vote:
 

I just tested with a default Alloy Site.

Episerver Forms 4.25, submit button has the classes Form__Element FormExcludeDataRebind FormSubmitButton.

Epserver Forms 4.29, submit butten has no classes.

I do not know why the classes has been removed.

#224502
Edited, Jun 22, 2020 5:43
Vote:
 

Yeah, I'm not 100% sure on this either. Great that I'm not the only one seeing this issue after the update.

Could this be a bug and not intentionally meant to be implemented? Unless otherwise, would it be worth raiseing a bug for this do you know? Never experienced an issue so far with any upgrades.

Kind regards,

Guy

#224503
Jun 22, 2020 4:47
Vote:
 

It looks like the form is behaving as expected, so maybe the classes was removed intensionally.

If you are unsure, you could:

#224504
Edited, Jun 22, 2020 4:57
Vote:
 

No dramas on that, I did try and have a look too, didn't see anything mentioned either.

But I'll contact support and see if it is intended or not...

Appreciate the advice and feedback Tomas!

Kind regards,

Guy

#224506
Jun 22, 2020 5:36
Vote:
 

This issue should be obsoleted on Forms 4.29.1. Please check!

#225192
Jul 08, 2020 6:21
Tomas Hensrud Gulla - Jul 08, 2020 6:53
What does that mean? The classes are back? Or they were removed on purpose?
Dac Thach Nguyen - Jul 08, 2020 6:55
I mean the classes are back
Guy Kimpton - Jul 08, 2020 7:46
Heya, have updated earlier before and looks like the classes are now back. Appreciate the reply and I don't see any other issues at the moment.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.