EPiServer.Forms.Helpers.Internal.FormsExtensions: cannot get all types from assembly MySql.Web

Vote:
 

We are getting this seemingly innocuous error in our logs from Episerver Forms.

There is a forum post referencing it here from early 2019:

https://world.episerver.com/forum/developer-forum/episerver-forms/thread-container/2019/1/exception-from-formsextensions-cannot-get-all-types-from-assembly/#200741

But it is unclear whether an official bug was ever logged, or if it was addressed along the way and something else is going wrong in my solution.

Any update from the Episerver team?

#208805
Edited, Nov 02, 2019 0:31
Vote:
 

Hi Drew,

I think the bug Reported by @Quan is this

https://world.episerver.com/support/Bug-list/bug/AFORM-2175

This seems to be closed with some feedback use, ITypeScannerLookup intead AppDomain.CurrentDomain.GetAssemblies.

#208825
Nov 03, 2019 14:53
Vote:
 

Hey dude!

Yep we are on Forms 4.26.0 and according to the bug it was fixed already. 🤷‍♂️

#208995
Edited, Nov 05, 2019 18:28
Vote:
 

So, are you still getting that error?

#208999
Nov 05, 2019 18:59
Vote:
 

No. We had a mismatched version in our Forms packages. Fixing that appears to have solved it.

Here is what it looked like when it was broken:

  <package id="EPiServer.Forms" version="4.26.0" targetFramework="net48" />
  <package id="EPiServer.Forms.Core" version="4.27.0" targetFramework="net48" />
  <package id="EPiServer.Forms.UI" version="4.27.0" targetFramework="net48" />

After getting them all on 4.27, we stopped getting the error:

  <package id="EPiServer.Forms" version="4.27.0" targetFramework="net48" />
  <package id="EPiServer.Forms.Core" version="4.27.0" targetFramework="net48" />
  <package id="EPiServer.Forms.UI" version="4.27.0" targetFramework="net48" />

#209540
Nov 17, 2019 16:01
Vote:
 

Nice finding.

So, was that hit and try :) 

Or it was in list on broken changes? If yes, you sould add link as well.

#209542
Nov 17, 2019 18:37
Vote:
 

Stumbled upon it accidentally. Someone had upgraded all our NuGet packages along the way. Afterwards I noticed it working

#209543
Nov 17, 2019 19:00
Praful Jangid - Nov 17, 2019 19:30
Great..
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.