Pardot Connector and Episerver Forms

Vote:
 

Im going to be adding the Pardot connector into my Episerver 9 project, the documentation only mentions its useage with XForms and not Forms Add-ons is it possible to use Pardot connector with new forms and is their documentation on how to set this up ?

The Documentation for Xforms and Pardot integration can be found here : http://webhelp.episerver.com/latest/addons/marketing-automation/pardot.htm

#160679
Oct 03, 2016 12:58
Vote:
 

Old XForm and new Episerver Forms basically works with the MarketingAutomationIntegration.Core (MAI.Core). It does not care about which connector on the other side.

Pardot connector is one add-in for the MAI.Core, so I think it should work.

I will also forward this thread to MAI team to add more information if any.

#160682
Oct 03, 2016 13:39
Vote:
 

Thank you, it might be worth updating the documentation as well, with how to use with Epi Forms


Regards


Minesh

#160683
Oct 03, 2016 14:02
Vote:
 

Hi Minesh

Here is the documentation on how to use MAI connectors with Epi forms.

http://world.episerver.com/add-ons/episerver-forms/forms-mai/

http://webhelp.episerver.com/latest/addons/episerver-forms/MAI.htm

Regards,

Sai.

#160775
Oct 05, 2016 21:37
Vote:
 

Hi Sai

I'm only ever seeing the Prospect Mapping option when setting up a form even though i have put in my correct credentials into Pardot, also the field mappings all seem the generic ones not the ones set in my Pardot setup.

Are we 100% confident the Pardot Connector will work with Episerver Forms ?

Thanks


Minesh

#162226
Oct 13, 2016 1:08
Vote:
 

Hi Minesh

The Pardot connector only maps to the "Prospect" object currently and can map to only the generic fields. Unfortunately, custom fields cannot be mapped as of now. The behavior is the same with XForms as well as EpiServer forms. We could consider this as a future enhancement. Please contact the Product Manager, Dick Sterry at dick.sterry@episerver.com to discuss this further.

Regards,

Sai.

#162410
Oct 13, 2016 23:08