Tagging user with @ in page comment does not list Active Directory users when using multiplexerproviders

Vote:
 
  • Issue description: In a site using the multiplexerproviders for both role and membership, tagging users with @ does not list Active Directory (AD) users when trying to add comment to a page. The function works well for users from SqlServerMembershipProvider or WindowsMembershipProvider. The tagging feature is also work well when configure ActiveDirectoryMembershipProvider and ActiveDirectoryRoleProvider for site only, AD users are suggested with @ in comments. 
  • CMS version information: 
    • EPiServer.CMS.Core version: 11.15.1
    • EPiServer.CMS.UI version: 11.25.0
  • Web.config part for multiplexerproviders
    • <membership defaultProvider="MultiplexingMembershipProvider" userIsOnlineTimeWindow="10" hashAlgorithmType="HMACSHA512">
      <providers>
      <clear />
      <add name="MultiplexingMembershipProvider" type="EPiServer.Security.MultiplexingMembershipProvider, EPiServer.Framework.AspNet"
      provider1="SqlServerMembershipProvider"
      provider2="ActiveDirectoryMembershipProvider"
      provider3="WindowsMembershipProvider" />
      <add name="SqlServerMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
      connectionStringName="EPiServerDB" enablePasswordRetrieval="false"
      enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false"
      maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0"
      passwordAttemptWindow="10" applicationName="/" />
      <add name="WindowsMembershipProvider" type="EPiServer.Security.WindowsMembershipProvider, EPiServer.Cms.AspNet" deletePrefix="BUILTIN\" searchByEmail="true"/>
      <add name="ActiveDirectoryMembershipProvider" maxInvalidPasswordAttempts="3" type="System.Web.Security.ActiveDirectoryMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
      connectionStringName="ActiveDirectoryProviderConnection"
      connectionUsername="########" connectionPassword="#########"
      enableSearchMethods="true" attributeMapUsername="sAMAccountName" />
      </providers>
      </membership>
      <roleManager enabled="true" defaultProvider="MultiplexingRoleProvider" cacheRolesInCookie="true">
      <providers>
      <clear />
      <add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer.Framework.AspNet"
      provider1="SqlServerRoleProvider"
      provider2="ActiveDirectoryRoleProvider"
      provider3="WindowsRoleProvider"
      providerMap1="SqlServerMembershipProvider"
      providerMap2="ActiveDirectoryMembershipProvider"
      providerMap3="WindowsMembershipProvider" />
      <add name="SqlServerRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="EPiServerDB" applicationName="/" />
      <add name="ActiveDirectoryRoleProvider" type="EPiServer.Security.ActiveDirectoryRoleProvider, EPiServer.Cms.AspNet"
      connectionStringName="ActiveDirectoryProviderConnection"
      connectionUsername="#######" connectionPassword="#######" attributeMapUsername="sAMAccountName" />
      <add name="WindowsRoleProvider" applicationName="/" type="EPiServer.Security.WindowsRoleProvider, EPiServer.Cms.AspNet"/>
      </providers>
      </roleManager>
  • Screen shots:

#223548
Edited, May 29, 2020 11:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.