No usage warning when deleting an image referenced in a PropertyList

Vote:
 

When deleting an image (or any other asset, I suppose) used in a PropertyList, the "The media is used in the following places. To avoid errors on the site, make sure that the media is not used anywhere." warning doesn't appear.

I guess it's because the content type only references the data model used in the property list and not the image itself, but I've been contacted by customers about this that have removed images believing they aren't used anywhere so it would be nice to be able to resolve it.

I've tried it in both CMS 10.xx.xx and 11.xx.xx with the same result.

Steps to reproduce:

1. Reference an image in a property list
2. Delete the image from the assets folder

Expected behaviour:

Actual behaviour:

#209253
Nov 12, 2019 14:48
Vote:
 

As described at the top of this page, PropertyList is «unsupported functionality». I think this is one of many things lacking...
https://world.episerver.com/documentation/developer-guides/CMS/Content/Properties/generic-propertylist/

#209267
Edited, Nov 13, 2019 6:30
Vote:
 

First, just to clarify, are you refering to a PropertyContentReferenceList or a custom PropertyList where the item type has a ContentReference property?

If it's the former, this would be a bug and we would appreciate if you could report it to Support.

If it's the latter, it's indeed as Tomas said one of the things that the PropertyList lacks support for and also one of the reasons why we have chosen to discourage using PropertyList with complex objects.

#209269
Nov 12, 2019 21:19