Problems with Web Parts in 4.62

Vote:
 

I've added the files and configuration for Web Parts from the ASP.NET 2.0 templates. But when I try registering a Web Part in the admin-page, the name and the description are empty, and the registered Web Part can't be added into a page using the SelectedWebPart property on the template.

When I'm trying to remove the registered Web Part, I get the following error message:

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[NullReferenceException: Object reference not set to an instance of an object.]
EPiServer.WebParts.Admin.WebPartRegistrationFactory.Delete(WebPartRegistration registration) +9
EPiServer.WebParts.Admin.WebPartRegistrationFactory.Delete(String name) +48

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
System.RuntimeMethodHandle._InvokeMethodFast(Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner) +0
System.RuntimeMethodHandle.InvokeMethodFast(Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner) +72
System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks) +371
System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +29
System.Web.UI.WebControls.ObjectDataSourceView.InvokeMethod(ObjectDataSourceMethod method, Boolean disposeInstance, Object& instance) +480
System.Web.UI.WebControls.ObjectDataSourceView.InvokeMethod(ObjectDataSourceMethod method) +38
System.Web.UI.WebControls.ObjectDataSourceView.ExecuteDelete(IDictionary keys, IDictionary oldValues) +1088
System.Web.UI.WebControls.ObjectDataSource.Delete() +15
EPiServer.WebParts.Admin.WebPartAdmin.DeleteRegistration(Object sender, CommandEventArgs e) +93
System.Web.UI.WebControls.Button.OnCommand(CommandEventArgs e) +105
System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +163
System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +7
System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +11
System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +33
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1746

Any ideas of what might be the problem?

#22502
Aug 07, 2008 9:31
Vote:
 

Found this in the release notes for 4.62 under known issues:

45655
Administration UI for webparts registrations does not handle non default IdSeparator

46001
Register web parts get blanked

Maybe I have to solve this without web parts...

 

#22508
Aug 07, 2008 11:20