Problems with zh-CHT language

Vote:
 

I created a new language of type Chinese (zh-CHT) and now the site is creating a null reference exception. I've tried different combinations of enabling/disabling the language but I can't seem to find a way of deleteing the Chinese language on the homepage (StartPage) as "Delete Language" is greyed out.

 

The stack trace is :

 [NullReferenceException: Object reference not set to an instance of an object.]
EPiServer.DataAccess.PageLoadDB.LoadPageInternal(PageReference pageLink, AbstractCommand cmd) +362
EPiServer.DataAccess.PageLoadDB.LoadPage(PageReference pageLink) +230
EPiServer.LocalPageStore.GetPageLocal(PageReference pageLink, ILanguageSelector selector) +190
EPiServer.<>c__DisplayClass4.b__3() +24
EPiServer.Core.OptimisticCache`1.Read(String cacheKey, ReadAndCacheObject`1 readAndCacheObject) +306
EPiServer.LocalPageStore.GetPageRaw(PageReference pageLink, ILanguageSelector selector) +218
EPiServer.LocalPageStore.GetPage(PageReference pageLink, ILanguageSelector selector, AccessLevel access) +502
EPiServer.DataFactory.GetPage(PageReference pageLink, ILanguageSelector selector, AccessLevel access) +286
EPiServer.Web.FriendlyUrlRewriteProvider.GetPageByPath(PageReference startPage, String path, LanguageBranch languageBranch, AccessLevel access) +329
EPiServer.Web.FriendlyUrlRewriteProvider.GetPageFromStartByPath(String path, LanguageBranch languageBranch, AccessLevel access) +120
EPiServer.Web.FriendlyUrlRewriteProvider.ConvertToInternalInternal(UrlBuilder url, Object& internalObject) +595
EPiServer.Web.FriendlyUrlRewriteProvider.ConvertToInternal(UrlBuilder url, Object& internalObject) +379
EPiServer.Web.UrlRewriteModule.HttpUrlRewriteToInternal(UrlBuilder url) +253
EPiServer.Web.UrlRewriteModuleBase.BeginRequestEventHandler(Object sender, EventArgs e) +204
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +92
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64

 

and I also get this message sometimes when view the site -

"Please select a specific culture, such as zh-CN, zh-HK, zh-TW, zh-MO, zh-SG. "

 Any help would be appreciated.

 

Kind Regards,

Chris 

#19939
May 15, 2008 16:40
Vote:
 

Hi Chris,

This is a known issue in EPiServer:

#8777: Adding a page in zh-CHS produces a System.ArgumentException 

The workaround is to use a non-neutral culture for Chinese, for instance ZH-cn.

Have you tried disabling the language(zh-CHS) in Admin mode?

#19940
May 15, 2008 16:57