Migration Tool - Validation of configuration failed

Vote:
 

Hi!

Im getting following error message while trying to migrate a 4.62 site to CMS 5 with the new migration tool (rc1):

Validation of configuration files failed.
General errors:
Validation failed: Line 1: Incorrect syntax near '('.

The message pops up emediatly after starting the migration. Obviously somethings wrong in one of the web.config files but I dont now which one and whats causing the error. I have followed the instructions in the technical note. Anyone who has experienced the same problem?

 
Regards, Tony 

#20415
May 28, 2008 12:00
Vote:
 
Hi,

I had the same problem!

It's a syntax error in a SQL query, obviously you cannot run the migration tool on a site installed on SQL Server 2000. SQL Server 2005 seems to be an undocumented prerequisite for running the migration tool.

I had to upgrade the database.

When I got past that problem I got stuck on another problem. The migration tool requires to have both sites up and running. But since I'm testing this in a developer computer running XP I can't have two sites up and running at the same time.


#20417
May 28, 2008 13:38
Vote:
 
Thank you Mikael! I will upgrade the database and try again.
#20419
May 28, 2008 13:55
Vote:
 

Hi Mikael and Tony,

Mikael is correct, you need to use SQL 2005 when using the migration tool. It's something we've missed in the documentation and this will be corrected. It will probably be some kind of better error msg in the migration tool aswell when we release the final version.

Regarding Mikaels problem, you don't need to run two sites when using the migration tool. It's enough to have a SP2 site running on your computer. You do however need to have the EPiServer 4.62 dll's registered in the GAC on the server. From the migration tool tech-note:

Ensure that the EPiServer 4.62 assemblies are already installed on the EPiServer CMS 5 SP2 site machine - in the GAC (Global Assembly Cache). Copy the assemblies to the CMS 5 site machine if they do not exist there. The EPiServer 4.62 assemblies and their versions are listed at the bottom this tech note. 

#20428
May 28, 2008 16:45
Vote:
 

Hi,

I'm suppose to migrate a site to CMS 5, but I don't have a SQL 2005 Server. From reading this conversation, manuals and tech notes I've come to the conclusion that SQL 2000 is ok for installing and running CMS 5, but you need SQL 2005 for running the Migration Tool, correct? Is there any workaround for the migration tool - for example - is it possible to do the database migration in SQL 2005 and then move the database back to a SQL 2000 Server?

Regards, Linda

#21328
Jun 26, 2008 13:23
Vote:
 

Sorry Linda - you've read wrongly I believe.  You need 2005 for running CMS 5 in all cases.

#36584
Feb 03, 2010 15:54