create language for root

Vote:
 
We get an error in CMS5 when "creating a new language" for the root page. This seems to be due to a bug in AddInheritedPageData which does no error checking for invalid values for PageReference: pageData.ParentLink in the beginning. Stack trace: [ArgumentNullException: Paramater has no page set Parameter name: pageLink] EPiServer.DataFactory.GetPage(PageReference pageLink, ILanguageSelector selector, AccessLevel access) +475 EPiServer.Core.CreatePageData.AddInheritedPageData(PageData pageData, PageType pageType) +147 EPiServer.Core.CreatePageData.DefaultPageData(Int32 pageTypeID, PageReference parentPageLink, ILanguageSelector selector) +352 EPiServer.LocalPageStore.CreateLanguageBranch(PageReference pageLink, ILanguageSelector selector, AccessLevel access) +147 EPiServer.DataFactory.CreateLanguageBranch(PageReference pageLink, ILanguageSelector selector, AccessLevel access) +332 EPiServer.DataFactory.CreateLanguageBranch(PageReference page, ILanguageSelector selector) +11 EPiServer.UI.Edit.EditPanel.get_CurrentPage() +361 EPiServer.UserControlBase.get_CurrentPage() +21 EPiServer.UI.Edit.XFormPostings.GetCurrentPage() +23 EPiServer.UI.Edit.XFormPostings.PageContainsFormProperties() +27 EPiServer.UI.Edit.XFormPostings.List() +6 EPiServer.PlugIn.AssemblyTypeInfo.UseCustomLoader(Type type, PlugInAttribute matchAttribute, ArrayList list) +46 [PlugInException: A error occured while calling ICustomPlugInLoader.List from "EPiServer.UI.Edit.XFormPostings": Paramater has no page set Parameter name: pageLink] EPiServer.PlugIn.AssemblyTypeInfo.UseCustomLoader(Type type, PlugInAttribute matchAttribute, ArrayList list) +144 EPiServer.PlugIn.AssemblyTypeInfo.ListPlugInDescriptorsForSort(PlugInAttribute matchAttribute, ArrayList list) +188 EPiServer.PlugIn.PlugInLocator.Search(PlugInAttribute matchAttribute) +171 EPiServer.UI.WebControls.TabStrip.LoadPlugIns() +99 EPiServer.UI.WebControls.TabStrip.OnInit(EventArgs e) +38 System.Web.UI.Control.InitRecursive(Control namingContainer) +321 System.Web.UI.Control.InitRecursive(Control namingContainer) +198 System.Web.UI.Control.InitRecursive(Control namingContainer) +198 System.Web.UI.Control.InitRecursive(Control namingContainer) +198 System.Web.UI.Control.InitRecursive(Control namingContainer) +198 System.Web.UI.Control.InitRecursive(Control namingContainer) +198 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +692
#17704
Mar 25, 2008 19:41
Vote:
 
I also have this problem with CMS5. When right clicking edit on root page I get the same error as above. This occurs after the language English was deleted.
#18542
Mar 25, 2008 19:43
Vote:
 
I have the same problem. I didn't delete English but i moved it down in the list.
#19829
May 07, 2008 17:17
Vote:
 
Bug #7733, fixed in SP2 which is very close to be released.
#19830
May 07, 2008 17:29
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.