Default.aspx and EpnStartPage

Vote:
 
Hi all. I have this problem. When i change EpnStartPage in web.config to a page that uses for example /flashpage.aspx instead of default.aspx I get an error saying that the default.aspx don't match the flashpage.aspx. Why is that? Am i not able to dynamically decide which startpage to use? How can I solve this? Do I need to use default.aspx for some kind of loader for all the other files? Best regards Mattias Bomelin The current template "/Default.aspx" does not match the specified page type file "/Flashpage.aspx" Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: EPiServer.Core.EPiServerException: The current template "/Default.aspx" does not match the specified page type file "/Flashpage.aspx" Source Error: Line 48: // Line 49: InitializeComponent(); Line 50: base.OnInit(e); Line 51: } Line 52: Source File: \\xxxxx\Inetpub\xxxxx\default.aspx.cs Line: 50 Stack Trace: [EPiServerException: The current template "/Default.aspx" does not match the specified page type file "/Flashpage.aspx"] EPiServer.PageBase.ValidatePageTemplate() +668 EPiServer.PageBase.OnInit(EventArgs e) +532 EPiServer.TemplatePage.OnInit(EventArgs e) +96 EPiServerSample.Default.OnInit(EventArgs e) in \\hal\Inetpub\proviva\default.aspx.cs:50 System.Web.UI.Control.InitRecursive(Control namingContainer) +321 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +692
#17621
Mar 25, 2008 19:33
Vote:
 
The problem here is most likely that the document settings in IIS defaults to default.aspx. When the browser is loading http://localhost/ the IIS redirects to default.aspx. Enter the IIS, Right-click "Properties" of your web site, Tab "Document", and put "flashpage.aspx" on top of the list of default documents. /Marten Berg
#18461
Mar 25, 2008 19:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.