Episerver bug with ASP.NET 2.0 web.config file

Vote:
 
Hi, I've been debugging like crazy for the last few hours, until I figured out what was causing the following exception. [NullReferenceException: Objektreferensen har inte angetts till en instans av ett objekt.] EPiServer.ConfigFileSettings.get_AuthenticationMode() +23 EPiServer.ApplicationConfiguration..ctor(String configFileName) +753 EPiServer.Global.get_EPConfig() +79 EPiServer.Global.ᐁ() +99 EPiServer.Global..ctor() +340 Connex.Intra.Web.Global..ctor() in C:\projects\xxx\xxx\Global.asax.cs:24 No matter what page I requested, the exception was thrown. I found this in my Web.config: If I remove the xmlns attribute, everything works great. So where did it come from? Well, yesterday or so I was poking around in IIS manager in the ASP.NET tab, where you can alter the configuration (web.config). When you save the settings there, the xmlns attribute is added to the Configuration element, and EPiServer crashes when it tries to parse it. Not a big issue, but in case more ppl stumbles upon this.
#17544
Mar 25, 2008 19:33
Vote:
 
Oh. And I'm running 4.60. Maybe fixed in 4.61?
#18379
Mar 25, 2008 19:43
Vote:
 
You are right, the namespace attribute is added by the asp.net extension of the IIS properties dialog and the issue is solved in 4.61.
#18380
Mar 25, 2008 19:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.