EPiServer 4.60(hotfix 2) PostBack and Caching doesn‘t work

Vote:
 
Information om själva felet (Obs, det är inget fel man får utan jag anser att det är fel i implementation av EPiServers postback hantering) Jag har en sida med navigering och ett formulär. Navigeringen på sidan är satt till att ha en output cache som variera på 2 parametrar språk och id (sidans id). Form taggen ser ut på följande sätt:
Dvs vi har även parametrar i URL:en, detta fungerade i 4.51. När jag postar formuläret, så kommer jag till en sida som heter post.aspx. utan parametrar. (Vilket är lite konstigt på flera sätt eftersom jag vill till default.aspx med parametrar) Vilket medför att cachning blir samma för denna sidan som använder detta formulär på oavsett vilket språk jag har. Detta anser jag är ett fel i EPiServers postback implementering, eftersom navigering blir correct om jag tar bort min output cache. Så här ser taggen ut för outputcachen. <%@ outputcache duration="300" shared="True" varybyparam="epslanguage;Mode;id" %> Är det någon som vet hur man kan komma runt detta problem, vi kan inte ta bort cachen eftersom vi har en väldigt performance krävande site. Jag har skickat detta till EPiServer supporten (i måndags 22/5) oxå, men ännu inte fått något svar. Mvh Jörgen
#17526
Mar 25, 2008 19:33
Vote:
 
A translation of this would be nice - please - anyone? Have a Postback issue too! but not just with Hotfix 2 Thankc Cameron
#18349
Mar 25, 2008 19:43
Vote:
 
Hi the friendly URL package is going to change the action tab for the post back handling in the web control "FriendlyUrlRegistration" so the postback is done to the friendly URL instead of the original URL, to read more about this in the technical note "Friendly URL.pdf"
#18350
Mar 25, 2008 19:43
Vote:
 
A short description of our problem (we have several other problems/issues with the friendlyUrl implementation, but we can't turn it of since our customer wants it :-( ) When we are doing a postback in our system we want the landing page to have the url www.xxx.com/default.aspx?id=34&lng=sv. But the friendlyUrl thinks that www.xxx.com/post.aspx is better. A workaround for this issue is to do the following in the aspx page. override protected void ValidateFriendlyUrl() {}
#18351
Mar 25, 2008 19:43
Vote:
 
If you change the parameter EPsFriendlyUrlExtension to “/default.aspx” you get the postback to go to default .aspx. The parameters id and epslanguage is removed because it is already in the URL.
#18352
Mar 25, 2008 19:43
Vote:
 
Hi, I have similar problems. The url I´m having problems with looks like this: http://localhost/Seminarier/Tipsa-en-van/?semID=1420 This page has a post-back button which makes the post to a page: http://localhost/Seminarier/Tipsa-en-van/Post.aspx So I lost my querystrings parameters, is there a way to keep them? They are crusial for the site which is running without user friendly url:s today.
#18353
Mar 25, 2008 19:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.