Problems updating from 4.41(.4.71) to 4.50

Vote:
 
I tried to update a 4.41 installation to 4.50. First the administrations interface becomes completely messed up. Thats because there is no system.css, so I renamed the system_template.css. This fixes some problems, but a closer look at it show that there is $EPiRootDir$ (or something like that). Ok, replace those with the correct search path and voíla it works, but it can't be the right way to do this. Is there anyone that has a suggestion of the right way to do it? reg //Stefan
#17443
Mar 25, 2008 19:33
Vote:
 
Hi, It's probably the same issue as this: http://www.episerver.com/templates/ForumItem____4135.aspx /Tobias
#18211
Mar 25, 2008 19:43
Vote:
 
nice, but it would nicer if the URL worked ;) //Stefan
#18212
Mar 25, 2008 19:43
Vote:
 
Hi there, This is actually a new feature of EPiServer 4.50 called dynamic styles sheets (or something like that). It allows you to have dynamic paths for predefined things in your style sheets. How it knows a style sheet is dynamic is with the _template suffix. To get it to work properly you need to make sure you have the /util/NotFound.aspx page set as your custom 404 page. Jeremy.
#18213
Mar 25, 2008 19:43
Vote:
 
Correct Jeremy. You can have your own .aspx file also, the point is to have the 404 redirected to the ASP.NET environment. The HTTP module SpiderSupport (defined in web.config) does the actual path mapping for dynamic stylesheets, simple address and unified file system.
#18214
Mar 25, 2008 19:43
Vote:
 
hi everyone where do you get hold of that kind of information? Cause I can't find it in the book "Developing with EPiServer" or in the pdfs on the site regs //Stefan
#18215
Mar 25, 2008 19:43
Vote:
 
Hello Stefan! It seems the only public information about this is published in the following faq: http://www.episerver.com/templates/faq.aspx?id=4112 I'll look up if we can add this to the sdk or perhaps a tech note for future releases.
#18216
Mar 25, 2008 19:43