Xform and send e-mail

Vote:
 
Hi, I get an error (see below) when I push the send button on a Xform when I have selected that the result should be sent by e-mail (both combined with and without 'store in database'). Just saving to database works great. I'm using version 4.50. Normal forms works fine. Anyone know anything about this? thanks /Tobias Exception Details: System.NullReferenceException: Object reference not set to an instance of an object. Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [NullReferenceException: Object reference not set to an instance of an object.] System.Xml.XmlStreamReader.Read(Byte[] data, Int32 offset, Int32 length) +51 System.Xml.XmlScanner..ctor(XmlStreamReader reader, XmlNameTable ntable, Encoding enc) +196 System.Xml.XmlTextReader..ctor(String url, Stream input, XmlNameTable nt) +102 System.Xml.XmlTextReader..ctor(Stream input) +80 EPiServer.XForms.Implementation.EMailConnection.ᐁ(XmlDocument ) +249 EPiServer.XForms.Implementation.EMailConnection.ᐁ(IItem ) +103 EPiServer.XForms.Implementation.EMailConnection.SendEmail(Object sender, ChannelEventArgs e) +65 EPiServer.BaseLibrary.Channel.ChannelEventHandler.Invoke(Object sender, ChannelEventArgs e) +0 EPiServer.Implementation.SynchronousChannel.Send(IItem item) +49 EPiServer.Implementation.DefaultRepository.Send(String channelId, IItem item) +35 EPiServer.XForms.XFormData.Send(Guid formId) +111 EPiServer.XForms.WebControls.XFormControl.SubmitForm(ChannelOptions options) +831 EPiServer.XForms.WebControls.Submit.SubmitForm(Object sender, EventArgs e) +91 System.Web.UI.Control.OnLoad(EventArgs e) +67 System.Web.UI.Control.LoadRecursive() +35 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Control.LoadRecursive() +98 System.Web.UI.Page.ProcessRequestMain() +750
#17401
Mar 25, 2008 19:33
Vote:
 
Hi, this problem is a bug in EPiServer 4.50, the XSLT resource to transform the XForm data to a mail is missing in the XForms assemly. To go around the problem it is possible to add a custom mail handler, see http://www.episerver.com/templates/CommunitySample____4137.aspx
#18149
Mar 25, 2008 19:43
Vote:
 
There is now a hotfix that should take care of this issue. Please contact episerver4@support.ep.se to get this hotfix.
#18150
Mar 25, 2008 19:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.