Multi language problem

Vote:
 
(EPiServer v4.31.4.47) I have a multi language site (Swedish and Norwegian, with Swedish being the default language). On the site, I have a page type without language-aware properties (i.e. no ___SV etc). When I log in as an administrator and set my language to Swedish (or, for that matter, leave it empty), everything works as expected. I can enter values and publish the page, and everything is fine. However, if I change my language to Norwegian, the pages are shown as unpublished in the tree, and when I create a new page, it displays the tab with the Swedish flag. If I go to the Common tab, and change the language to Norwegian, and publish the page, it is still being displayed as unpublished in the site tree. Is there some trick I can use to force publish a page in another language than the system default? Or is the best suggestion for solving this particular problem to make all properties on the page type multi language? As a side note, if I export the relevant pages from the production site and imports them on my development machine (running EPiServer v4.31.0.47), everything works as expected. Best regards, /Paddy
#17391
Mar 25, 2008 19:32
Vote:
 
Hello Patrik! A language in a multi language page is only considered to be published when there are at least on property for the language that has a value. If you have a multi language page you have to set at least one value for the language. A page where you have only set common properties will not be considered to be published in any language. The language property is only used to "bind" a specific version of the page to a language. This property has been hidden for multi language pages in later versions of episerver as this cannot be modified by an editor on multi language pages. I'm not sure why the pages would appear as published on your developer site but it might have to do that you have different versions of the episerver.dll file.
#18129
Mar 25, 2008 19:42
Vote:
 
hi We got the same problem. A page that is published in a language other than swedish is marked as unpublished, but when we get the page in a pagelist the page is visible. We're using version 4.51.XX.XX. Is there a work around to this? regs //Stefan
#18130
Mar 25, 2008 19:42
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.