Multi language: Published pages marked as not published

Vote:
 
I'm using the multi language runtime with two active languages: Swedish and English. However, if I publish a page which isn't in the default language (read Swedish), the page get marked as "not published" in the tree menu to the left in edit mode. I guess that depends on the fact that the tree menu shows the status of the pages in the default language. The page _is_ marked as published in the right view. The big problem comes when using the link editor since the page isn't shown there (which, of course, makes it hard to create a link to that page). Is this a known bug or have I forgotten something? regards Peter
#17384
Mar 25, 2008 19:32
Vote:
 
Which version of EPiServer are you using? Also, if your (the current logged in editor) language is set to Swedish, and you publish a page in English, this page will be marked as Unpublished in the left tree. This is because this menu displays the publishing status of the pages in your language. If you however change your language to English, the page will appear as published in the left tree, and the page also then should appear in the link editor. Aside: if you don't have any user language specified (blank), then it will use the system language defined in Admin -> system settings. Frank :)
#18112
Mar 25, 2008 19:42
Vote:
 
In the link editor in EPiServer 4.50 you are able to link to pages that are not published. This works for both multi language and regular pages.
#18113
Mar 25, 2008 19:42
Vote:
 
Ok, thanks! But the answer for version 4.41 is that the link editor cannot find pages that are published only in English when the default language is Swedish? regards Peter
#18114
Mar 25, 2008 19:42
Vote:
 
That is correct. You have to upgrade your EPiServer version for this to work.
#18115
Mar 25, 2008 19:42