Problem med PageName

Vote:
 
[Detta gäller version EPiServer 4.30, skarp version.] Efter att ha slagit på MultiLanguageRuntime igår (problemet uppträdde inte förrän idag) så har jag följande problem på en sida som använder sidtypen Start Page: Jag har lagt till några "språkberoende" egenskaper till sidtypen, i övrigt är inställningarna i själva sidtypen identiska med de som levereras i demositen (aspx-filen är däremot förändrad). När jag i redigeringsläget går in och tittar på egenskaperna under fliken SV, så ser allting rätt ut. Ovanför flikarna står det "Välkommen Startsida Publicerad version", men när jag går in på fliken Gemensamma, så ändras det till "Common Startsida Publicerad version", och Namn-egenskapen har ändrat värde till Common. Klickar jag "Spara och publicera" så sparas Common till databasen, vilket visas ute på siten (och i trädet inne i redigeraläget. Går jag tillbaka till SV-fliken, så ändras rubriken tillbaka till "Välkommen Startsida Publicerad version", och klickar "Spara och publicera" så ändras PageName tillbaka till det som det var från början (dvs "Välkommen"). "Common" är något jag aldrig skrivit in någonstans, så det måste vara något genererat någonstans i EPiServers hemliga inre. Jag har suttit ett tag nu och försöka komma underfund med vad det kan vara som orsakat detta, och hur jag skall åtgärda det, men inte hittat något sätt (förutom att radera allting och börja om från början). Någon som har någon tanke om vad det är som orsakat detta märkliga beteende, eller kanske någon idé om hur jag åtgärdar det?
#17271
Mar 25, 2008 19:32
Vote:
 
Hej Patrik! Det skulle vara intressant att veta om du har språkkodade egenskaper för sidans namn, dvs PageName___SV osv.
#17888
Mar 25, 2008 19:42
Vote:
 
Hej Linus! Jag hade ju givetvis inte läst igenom den där sidan om hur man aktivera flerspråksstöd i EPiServer... Vilket jag nu gjort, lagt till PageName___SV (etc.) och nu fungerar det som det skall. /Paddy
#17889
Mar 25, 2008 19:42
Vote:
 
Hej! Jag verkar ha samma problem. Jag har 2 engelska och 2 svenska properties samt ett antal common (icke språkspecifika properties såsom bilder m.m.). När jag sparar sidan så verkar den sätta "Common" som sidnamn. Fastän jag har fyllt i värden under båda språken. Dock verkar det inte vara på alla sidor som detta sker, dvs jag har andra sidor i trädet utav samma sidtyp men dessa fungerar att spara som dom skall. Jag kör version 4.31.0.47 av EPiServer. Mvh Stefan
#17890
Mar 25, 2008 19:42
Vote:
 
Ett tillägg är att den verkar ta bort namnet helt om jag står i editeringsläget på en av språken och tar "Save and publish". Då försvinner den alltså helt och det blir en tomrad i trädet, dock finns det någon transparant gif att klicka på så att man ändå kan komma in och editera sidan på nytt. Går man därefter in på sidans Commonflik så står det Common i Name fältet. Ändrar jag detta till t.ex. "Min sida" så sparas inte detta utan den uppdaterar trädet med texten "Common". /Stefan
#17891
Mar 25, 2008 19:42
Vote:
 
Fortfarande samma problem... är det nån på EP som har en lösning på detta? Svårt att förklara för kunden varför det blir som det blir... Här är en av mallarna jag har som det blir så på: http://www.adera.se/files/commonfelmall.epi4 (innehåller en PageType) Mvh Stefan
#17892
Mar 25, 2008 19:42
Vote:
 
Hei. Dette er et kjent problem i gjeldende versjon av EPiServer. Forhåpentligvis har de fått fikset det meste av disse typer feil i neste versjon. For mer informasjon, sjekk følgende side (Known issues in 4.31): http://www.episerver.com/templates/Page____5988.aspx Frank :)
#17893
Mar 25, 2008 19:42
Vote:
 
Hej! Detta skall vara åtgärdat till version 4.40 RC1 och vi hoppas kunna åtgärda alla kända buggar vad gäller flerspråksfunktionaliteten till skarpa versionen av 4.40.
#17894
Mar 25, 2008 19:42
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.