Error when upgrading from 4.20 to 4.21

Vote:
 
After what seemed like a sucessful upgrade from 4.20 to 4.21 I now get this error on every access to the site: Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: Unrecognized attribute 'validateRequest'. Source Error: Line 118: --> Line 119: Line 120: Line 121: Line 122: Source File: D:\Inetpub\EPiDemo\web.config Line: 120 -------------------------------------------------------------------------------- Version Information: Microsoft .NET Framework Version:1.0.3705.288; ASP.NET Version:1.0.3705.288
#17231
Mar 25, 2008 19:32
Vote:
 
Dette er for .NET FW 1.1, og gjør at du ikke får "A potentially dangerous Request.Form value was detected from the client" feilen ved bruk av Edit og DOPE. Installasjonsprogrammet ser at .NET FW 1.1 er installert, men om siten ikke kjører 1.1, men 1.0, så vil denne feilen oppstå. Løsningen er å ta bort linjen fra web.config. For mer info om validateRequest, se: http://www.microsoft.com/technet/prodtechnol/windowsserver2003/proddocs/standard/aaconpageselement.asp
#17839
Mar 25, 2008 19:42
Vote:
 
Finnes det noe sikkerhetsmekanismer lenger nede i episerver-produktet som tar hånd om valideringen av innholdet i typiske editor-inputs fra redaktørene? Denne settingen (validateRequest="false") er vel i bunn og grunn en åpning for å taste inn hva som helst? (Les: hack) Frank=)
#17840
Mar 25, 2008 19:42
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.