EPiServer.Framework.11.3.1 Install.ps1 causes exception (tested with Alloy)

Vote:
 

Hi, the EPiServer.Framework.11.3.1 Install.ps1 causes an exception when it tries to update the assembly binding for EPiServer.Data.Cache

Updating binding redirect for EPiServer.Data.Cache
The property 'oldVersion' cannot be found on this object. Verify that the property exists and can be set.
At C:\somepath\packages\EPiServer.Framework.11.3.1\tools\Install.ps1:59 char:5
+     $assemblyConfig.bindingRedirect.oldVersion = "0.0.0.0-" + $assemblyName.Vers ...
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
    + FullyQualifiedErrorId : PropertyAssignmentException
 
The property 'newVersion' cannot be found on this object. Verify that the property exists and can be set.
At C:\somepath\packages\EPiServer.Framework.11.3.1\tools\Install.ps1:60 char:5
+     $assemblyConfig.bindingRedirect.newVersion = $assemblyName.Version.ToString( ...
+     ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
    + FullyQualifiedErrorId : PropertyAssignmentException

Steps to reproduce:

  • VS2017 with Eppiserver CMS Visual Studio Extension, version 11.1.0.326
  • Create new Episerver MVC Alloy site with search (full-text)
  • Update Episerver NuGets to latest version (update 196)
  • the above error is logged in console

Looking at the web.config binding redirects the EPiServer.Data.Cache binding redirect is there twice like this:

      
        
        
      

Quick fix, remove the duplicate entry and change the version range and newVersion to 11.3.1.0

#186934
Jan 09, 2018 8:40
Vote:
 

Fixed in Episerver update 203: https://world.episerver.com/releases/episerver---update-203/

(EPiServer.Framework.11.3.4 package)

#188556
Feb 26, 2018 19:25
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.