How to move EpiServer Site

Vote:
 

Hi,

I'm a newbie with server. I need to move an existing site to another server.

What's the procedure? I can't find any articles regarding this one.

Thanks in advance.

Cheers,

Jan

#49066
Mar 03, 2011 5:29
Vote:
 

*including the database

#49067
Mar 03, 2011 5:30
Vote:
 

1) make a database dump

2) Install a fresh episerver site on the new server (without anything)

3) copy all your files inside the new site and all your vpp folders inside the vpp folder

4) create a new database based on #1

5) modify connection string to use your new database

Then you should be good to go

#49074
Mar 03, 2011 8:31
Vote:
 

When I browse my site, this shows up: "This installation contains only core files."

I believe this is because of the default.htm page. But what default document would I use? I don't see any web pages on the root site other than that default.htm with the "This installation contains only core files." content.

Thanks.

#49586
Mar 24, 2011 3:04
Vote:
 

By the way, I'm using Windows 7 Ultimate.

#49587
Mar 24, 2011 3:39
Vote:
 

By the way, I'm using Windows 7 Ultimate x64.

IIS 7.5.7600.16385

EPiServer CMS 6.0.530.0

#49588
Edited, Mar 24, 2011 3:39
Vote:
 

The "only core files" message usually appears when the pageStartId isn't set in the siteSettings of your web.config/episerver.config file.

But if that config key is incorrect, maybe more are? You should copy the configs from the other site as well (everything in the web root as Anders said)

#49592
Edited, Mar 24, 2011 9:05
Vote:
 

Well, I followed what Anders said and I literally copied all files from the live server.

This is also the behaviour I'm getting when I install a new site (with or without a database).

#49692
Mar 29, 2011 8:35
Vote:
 

If you navigate to the EPiServer.config and find the pageStartId attribute inside site settings, what is the value?

#49706
Mar 29, 2011 12:10
Vote:
 
pageStartId="41" I also had to do this command prior to the core files error: apppcmd migrate config mysite/. If it helps. I also added my alias in the EpiServerFramework.config file. I Also Edited the physical path (from episerver.config) of the episerver directories from program files to program files (x86). I'm running out of clues to make this one work.
#49880
Apr 05, 2011 2:23
Vote:
 

It Looks like it's just treating my site as an ordinary web site when I browse the alias.

#49881
Apr 05, 2011 2:25
Vote:
 

Do the machine you moved it to serve any aspx pages? If you did the move to a newly setup server it could be that .Net isn't activated for the IIS.

 

#49887
Apr 05, 2011 9:32
Vote:
 

Hi Petter,

It definitely serves aspx pages. I'm using this one for ASP.net/dnn sites.

#49891
Apr 05, 2011 10:10
Vote:
 

Do you have EPiServer installed on the machine you moved to?

#49893
Apr 05, 2011 11:03
Vote:
 

See if you can access edit/admin mode. If you can try accessing the root page using language prefix -> http://siteaddress.com/en/ or what ever language you have enabled on the site.

#49894
Apr 05, 2011 11:42
Vote:
 

Hi Jan,

Did you ever figure out the cause of this? I'm having the same problem and just can't figure out how to resolve. I have a site with start page ID set correctly, other sites work and go to the correct page on the same machine, but this one site keeps going to the message "This installation contains only core files.". 

If I specify a start page in the properties of the web project then it works but it only works with http://domain.com/path/to/page/specified.aspx rather than http://domain.com

This is a very frustrating mystery!

Any thoughts appreciated,

Mark

#51588
Jun 16, 2011 10:00
Vote:
 
Hi Mark,

Good for you it's working a little bit. I gave up a long time ago with the steps provided above.

Here's the procedure I use now in moving EPiServer sites:
1. Install EPiServer deployment center.
2. Copy site and vpp folders to the server.
3. Backup and restore copy of database
4. Setup IIS and point to Site folder.
5. Edit episerver.config siteURL and make sure the physicalpath entries are correct (VPP - around 9 entries in total)
6. Edit web.config modify correct location of VPP path (if applicable).
a. <imageGallery AbsoluthPath=
b. <documentArchive physicalPath=
c. <webmail diskCachePath=
7. edit connectionstrings in connectionstrings.config

NOTE: just make sure all physical path entries are valid and correct and you're good to go

I find this process easier and saves me a lot of time.
#51589
Edited, Jun 16, 2011 10:23
Vote:
 

If it is IIS7, check if <modules> and <handlers> are correct (compare with a site that works). IIS6, chack httpModules and httpHandlers.

#51590
Jun 16, 2011 12:04
Vote:
 

Thanks Erik, that was it and resolved the problem. I'm not really sure why these sections were missing in the first place though, curious....

Thanks again,

Mark

 

#51623
Jun 17, 2011 12:07
Vote:
 
#51627
Jun 17, 2011 13:13
Vote:
 
#51635
Jun 17, 2011 17:58