The term 'Get-EPiExpandedConfiguration' is not recognized at CMS 5 R2 SP2 upgrade

Vote:
 

Hi,

When trying to upgrade CMS 5 R2 SP1 to SP2 the installation process cannot complete due to an error:

An unhandled error has occured:
The term 'Get-EPiExpandedConfiguration' is not recognized as a cmdlet, function
, operable program, or script file. Verify the term and try again.
When executing

At C:\Program Files\EPiServer\CMS\5.2.375.236\Upgrade\System Scripts\Upgrade Si
te (SqlServer).ps1:171 char:45
+ $webConfigDoc = Get-EPiExpandedConfiguration  <<<< $targetWebConfigFile

If you look in the script-file you find the following code at line 171:

# Load web.config with all config sources into one file
$webConfigDoc = Get-EPiExpandedConfiguration $targetWebConfigFile

 ...wich is about the same as the error message in the installation log.

Anyone else seen this and know more about it?
Why is the term 'Get-EPiExpandedConfiguration' not recognized?
It doesn't seem to help to rerun the installation anyway.

Regards
//Nisse

#35740
Dec 22, 2009 12:18
Vote:
 

Hi,

Have seen this issue couple of times and those issues were solved by reparing installation for R2SP2. Have a look at this forum thread.
http://world.episerver.com/Templates/Forum/Pages/Thread.aspx?id=32180&epslanguage=en

 

 

#35742
Dec 22, 2009 12:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.