Load Balancing / Remote Events

Vote:
 

Am installing EpiServer CMS 5 for loadbalancing and have followed the impressive but uninformative guide: Event Management System Specification

Changes on one server (1) does not appear on the other (2), although they share the same database + VPP folders. The Remove Event listener on (1) reports the event, while server (2) reports nothing. The servers are on the same network with not hardware in between (apart frmo a switch).

Any ideas?

Should I use another UDP Multicast IP? Currently 239.255.255.19:5000

Thanks

#19333
May 04, 2008 17:22
Vote:
 

I would recommend you running the diagnostics application listed under Troubleshooting section of the tech note: Event Management System Specification

Are you using virtual servers?

#19341
Apr 04, 2008 14:50
Vote:
 

Thanks, I think we found the problem and yes we are using Virtual servers.

We are running NLM (Network Load Balancing) and it looks like that was messing things up. Once NLM was turned off Event Notification with the Multicast IP worked like a charm.

But we want NLM to work as well, so we're going to try adding another NIC (Network Interface) to each server and use one set for NLM and the other set for Event Notifications.

Hope it works! :-)

#19343
Apr 04, 2008 20:42
Vote:
 

You could take a look at my post at our blog too. I had some problems when I installed our serveres in a load balanced enviroment.

 Go to http://www.epinova.no/no/Blog/episerver_blog/ and look at the post "Validation of viewstate MAC failed" 

#19688
Apr 26, 2008 0:16
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.