License error: Could not load the provider

Vote:
 
Hello I am having a little brainer; I got my new license and copied the file in my project directory and my license directory for episerver manager. When i go to my localhost, i get a nasty little error, as such: System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode) +176 System.Management.ManagementObjectEnumerator.MoveNext() +418 ElektroPost.Licensing.RestrictionTypes.MACRestriction.ᐁ(ManagementObjectCollection ) +42 ElektroPost.Licensing.RestrictionTypes.MACRestriction.Setup() +67 ElektroPost.Licensing.LicenseData.Validate() +368 ElektroPost.Licensing.LicenseRuntime.ValidateLicense() +26 EPiServer.Core.Licensing.Test() +19 EPiServer.DataFactory.GetPage(PageReference pageLink, ILanguageSelector selector, AccessLevel access) +60 EPiServer.DataFactory.GetPage(PageReference pageLink, AccessLevel access) +89 EPiServer.PageBase.GetPage(PageReference pageLink) +167 EPiServer.SimplePage.get_CurrentPage() +176 At the episerver manager i get the error: License error; Could not load the provider Please help
#16987
Mar 25, 2008 19:30
Vote:
 
I have solved the problem. It turns out that episerver MUST check the MAC adress of all your network adapters installed. Which means that you can not have any network adapters disabled. You must also make sure you have WMI drivers installed with your network adapters. If you get any License failure, go check your WMI, by downloading a script that checks your WMI. WMIdiagnostic tool
#17158
Mar 25, 2008 19:31
Vote:
 

I just encountered this while setting up an old EPi 4 site on my local machine. The WMIdiagnostic tool from MS wouldn't work for my 64-bit Windows 7, but I got it working by using a new License.config bound to IP instead of MAC.

#51946
Jun 29, 2011 16:30
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.