Access to files/folders...

Vote:
 
I have created a folder "WebServices" and put a file "test.asmx" in that folder. But when I try to access that webservice I am forced to log in. Is it possible to add some settings/code telling EPiServer to let everyone access that file/folder without having to log in?
#16958
Mar 25, 2008 19:29
Vote:
 
You might want to put your web service in a different folder from the standard EPiServer ones. The reason you are getting a login prompt is because of the web.config default setting for the "WebServices" folder. You probably have something like this in the web.config file: I wouldn't recommend changing this as changing this to make it public will allow anyone to access the EPiServer web services. If you want this behaviour then change it to the following: Cheers, Jeremy.
#17133
Mar 25, 2008 19:31
Vote:
 
Jeremy has a point, but one way around this is setting authorization on a file-specific level in web.config. If you sadd one more location tag like below, it should work fine. You may need to set access in IIS and the file structure as well.
#17134
Mar 25, 2008 19:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.