Unable to login anymore

Vote:
 
I have an episerver website which works OK for long periods of time but then suddenly won’t allow me to log in to edit or admin mode. No error messages are displayed, the screen just refreshes. If I enter invalid login details then I get the appropriate error messages. I can fix the problem by restoring a backup of the episerver database which I have done several times on our development & test sites, but now it’s happened on our live site it’s become a bit more serious. Any ideas? Steve.
#16993
Mar 25, 2008 19:30
Vote:
 
Hi, What is your configuration? E.g. do you have load balanced, enterprice, web-farm etc? Have you a master/slave license setup? If so and if you have the master site offline, after 30 days and exception will be thrown on the slave site during site startup. If an exception is thrown then EPiServers Authentication configurations will not be setup correctly and leading to login problems. You should be able to login to edit and admin with a local administrator user (NT) if you in the web.config add Administrators to the location path for edit and admin. If you enable EPiServer Logging at DEBUG level and restart your site you should be able to catch the error. See http://www.episerver.com/en/EPiServer_Knowledge_Center/FAQ_EPiServer_4/1053/6486/ regards Per
#17160
Mar 25, 2008 19:31
Vote:
 
Our live configuration is load balanced with master/slave but our test site has a single episerver license. I’ve tried logging in as an administrator on our test site – no good. This is the debug output which seems to suggest that the authentication request succeeded (user coorsepi) but I just keep getting presented with the login box. 2007-10-03 15:46:07,074 3.1.1 Successfully executed scheduled job 8de3f2b0-6e12-4716-a6f9-736f7e2f8944 2007-10-03 15:48:06,263 1.2.1 Enter Global constructor 2007-10-03 15:48:15,028 1.2.2 Leave Global constructor 2007-10-03 15:48:16,060 1.2.1 Enter Global constructor 2007-10-03 15:48:16,138 1.5.1 Gatling compatibility disabled 2007-10-03 15:48:18,528 1.2.3 Authenticate request 2007-10-03 15:48:19,357 1.1.3 Page initialized 2007-10-03 15:48:19,357 http://stagehost.barbox.com/default.aspx?id=3|Page|c4z2a255ynb3sx45j52vc5v4|3|3|Anonymous|Start Page 2007-10-03 15:48:40,669 1.2.3 Authenticate request 2007-10-03 15:48:40,904 1.2.3 Authenticate request 2007-10-03 15:48:40,950 1.1.3 Page initialized 2007-10-03 15:48:50,513 1.2.3 Authenticate request 2007-10-03 15:48:50,513 1.1.3 Page initialized 2007-10-03 15:48:50,544 9.4.2 User was authenticated: coorsepi. IP: 192.168.10.76. 2007-10-03 15:48:50,716 9.4.2 User was authenticated: coorsepi. IP: 192.168.10.76. 2007-10-03 15:48:50,716 1.2.3 Authenticate request 2007-10-03 15:48:50,888 9.4.2 User was authenticated: coorsepi. IP: 192.168.10.76. 2007-10-03 15:48:50,888 1.2.3 Authenticate request 2007-10-03 15:48:50,888 1.1.3 Page initialized
#17161
Mar 25, 2008 19:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.