Installation problem - import publicPackage

Vote:
 
When trying to install EPiServer CMS on Vista Ultimate i get a 404.2 Error when the installation finish and the explorer window opens with this url: http://tgt61/epi1/web/admin/setup.aspx?InstallPackagesPath=C%253a%255cProgram%2bFiles%255cEPiServer%255cManager%255cModules%255cpublicPackage%255cImports The error message looks like this and I can't figure out wich ISAPI filter is wrong. HTTP Error 404.2 - Not Found Description: The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server. Error Code: 0x800704ec Notification: ExecuteRequestHandler Module: IsapiModule Requested URL: http://tgt61:80/epi1/web/admin/setup.aspx?InstallPackagesPath=C%253a%255cProgram%2bFiles%255cEPiServer%255cManager%255cModules%255cpublicPackage%255cImports Physical Path: C:\inetpub\wwwroot\epi1\web\admin\setup.aspx Logon User: Anonymous Logon Method: Anonymous Handler: AboMapperCustom-54399 Most likely causes: No handler mapping for this request was found. A feature may have to be installed. The Web service extension for the requested resource is not enabled on the server. The mapping for the extension points to the incorrect location. The extension was misspelled in the browser or the Web server. What you can try: Install the feature that handles this request. For example, if you get this error for an .ASPX page, you may have to install ASP.NET via IIS setup. Verify that the Web service extension requested is enabled on the server. Open the IIS Manager and navigate to the server level. In the Features view, double-click ISAPI and CGI Restrictions to verify that the Web service extension is set to Allowed. If the extension is not in the list, click Add in the Actions pane. In the Add ISAPI and CGI Restrictions dialog box, type the path of the .dll or .exe file in the ISAPI or CGI Path box, or click Browse to navigate to the location of the file. In the Description box, type a brief description of the restriction. (Optional) Check "Allow extension path to execute" to allow the restriction to run automatically. If you do not check this option, the restriction status is Not Allowed, which is the default. You can allow the restriction later by selecting it and clicking Allow on the Actions pane. Click OK. NOTE: Make sure that this Web service extension or CGI is needed for your Web server before adding it to the list. Verify that the location of the extension is correct. Verify that the URL for the extension is spelled correctly both in the browser and the Web server. Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.
#16995
Mar 25, 2008 19:31
Vote:
 
I found out what the problem was at last! There is a file called: applicationHost.config under %windir%\system32\inetsrv\config\ and in some way this file has been currupt. (The line-number ref can diff). On line 893 under section for handlers for the site episerver was installed at there are two handles added named: AboMapperCustom-62416 and AboMapperCustom-62417 and when they were added an extra backslash was added so the path to the dll-file look like this: scriptProcessor="C:\Windows\Microsoft.NET\Framework\v2.0.50727\\aspnet_isapi.dll" This makes IIS7 crash and the fix is just to take away the extra backslash so the two lines look like this: It worked for me.
#17162
Mar 25, 2008 19:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.