Does EPiManager support SQL Server 2005 as a database?

Vote:
 
I tried to install EPiServer using an SQL Server 2005 Express but EPiManager doesn't recognize the database it just tells me "SQL Server missing or access denied" when I try to list the databases on my local machine. Is this behavior expected or am I missing something? Regards Pontus
#16892
Mar 25, 2008 19:25
Vote:
 
You need to change the value in the "Server:" textbox from "machine_name" to "machine_name\SQLExpress" in order to get it to work correctly. The handling will be improved in the next release of EPiServer Manager.
#17044
Mar 25, 2008 19:31
Vote:
 
Now I have tried this but it still does not work. I have also enabled remote connection for both TCP\IP and Named Pipes in the SQL Server 2005 Surface Area Configuration utility but to no avail. It does not find the sql server. Any body got any ideas?
#17045
Mar 25, 2008 19:31
Vote:
 
We have upgraded the site http://r.ep.se from MSDE to MS SQL 2005 Express (the freeware version) in order to see if it might be possible to bundle the Express with EPiServer. From the limitations with Express, 2GB dataase and 1GB RAM it looks like it might power some pretty large sites. We will do some performance tests in the near future. I will ask Johan (who upgraded the server) to take a look at your problems. rgds, Mikael Runhem, EP
#17046
Mar 25, 2008 19:31
Vote:
 
Verify that tcp/ip (or named pipes, whichever is appropriate for your setup) really is enabled in SqlServer Configuration Manager.(tcp/ip is disabled by default) /johan
#17047
Mar 25, 2008 19:31
Vote:
 
Hi all! I found out what the problem was. The database was created with the compability level set to 9.0. When I changed it to 8.0 it worked fine. Pontus
#17048
Mar 25, 2008 19:31
Vote:
 
Hi Pontus Where did you change compability level? In the installation process of SQL Express? Thanks! Daniel
#17049
Mar 25, 2008 19:31
Vote:
 
I now have stumbled into the same problem.. Ive done everything up to the comp level. Where do I set that?
#17050
Mar 25, 2008 19:31
Vote:
 
I found out how and here it is if anyone else run into the problem: I found it after some searching. I installed the program "Microsoft SQl Server management Studio Express" from microsoft (works like enterprice manager for sql server 2000) and there I was able to change the compability level on the database. Though i still have problem installing EPiServer but I wrote about that in other thread.
#17051
Mar 25, 2008 19:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.