Installation on another port than 80?

Vote:
 
Is it possible to install EPiServer to another port than 80? I installed it to port 89 and all wen't OK without errors. When EpiManager was done there was error "The Parameter is incorrect" in IIS manager and site wouldn't start. Windows eventlog logged several errors like this: Event Type: Error Event Source: W3SVC Event Category: None Event ID: 1003 Date: *** Time: *** User: N/A Computer: *** Description: Cannot register the URL prefix 'http://localhost:89:80/' for site '5'. The URL may be invalid. The site has been deactivated. The data field contains the error number. For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 57 00 07 80 W..€ Is there a bug in EpiManager? Why does it try to register site url incorrect?
#16887
Mar 25, 2008 19:25
Vote:
 
Yes, it's possible to install episerver on other ports than port 80. I'm not sure about your error message though... Which Windows OS are you running? If you are installing this on a Win Xp machine, you can only run one website at the time. You need to stop your website at port 80 before you run your new website at port 89.
#17033
Mar 25, 2008 19:31
Vote:
 
A warning about using different ports. If you plan to run different environments on different ports such as acceptance test or when building a structure on port 8080 and then decide that you want to just rename 8080 to 80 when it comes time for production... beweare of the admin setting "Address to your website (e.g. http://www.x.y:8080)" Any links added will always refer to port 8080 as they are stored in the database and IIS has no idea. Search and replace is the solution. /John
#17034
Mar 25, 2008 19:31
Vote:
 
Windows 2003 Server SP1 Setup: - EPiServerManagerSetup1.1.msi - Online setup
#17035
Mar 25, 2008 19:31
Vote:
 
There's a bug in EPiServerManager 1.1. It registers site's address in IIS hostheader incorrectly. If I try to install site to my localhost at port 81 it registers site hostheader as "localhost:81". This causes error "parameter in incorrect" in IIS Manager and the site is always stopped. Removing or correcting hostheader from site fixes this. EP should fix this ASAP!
#17036
Mar 25, 2008 19:31
Vote:
 
These are the steps needed in order to use custom ports for the edit-/admin-mode in EPiServer: 1. Change EPnEditHttpPort and EPnAdminHttpPort to ex. 1234 och 5678 (This is done using the Manager) 2. Add the ports to the site in question using the properties dialog in the IIS. (under the web site tab, click the "advanced"-tab next to the "IP-address"-field.) 3. go to ex. http://localhost:1234/mysite/edit This should do it! PS. In the next version of the manager this will be handled automatically when setting the properties EPnEditHttpPort och EPnAdminHttpPort. DS.
#17037
Mar 25, 2008 19:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.