A new block created within a page with workflow should be approved and published at the same time with the page

Vote:
 

Our customer found that when a workflow is enabled and you click the "create a new block" link within a ContentArea of a page to build a block, after clicking "Create," it takes you back to the original page/block acting like the block has been published but it has not. This is leading to content authors building pages out with blocks that don't display on the front-end because they're not actually published.

This issue only occurs when the workflow is enabled and when using the "create a new block" link within a Contentarea field.

Later the customer found that the same scenario occurs with the "projects" feature in Episerver as well, so even with workflow disabled, if you're working on content in a project and create a block through the local dropzone link, it results in the same user experience issue where you think the block was set as ready to publish but it's still in draft mode. 

We hope the blocks created within page and project could be approved and published with pages and projects. So the user does not have to publish the blocks separately, since most time, the user does not realize the blocks are not published. 

#223168
May 20, 2020 14:46
Vote:
 

Hi XiangLan,
Have you looked into the Labs Block enhancements?  They may provide some of the functionality you're seeking.

#223170
May 20, 2020 16:34
Vote:
 

Hi Bob

The customer tried the Labs Block enhancements package referred by our engineer. It has the function there but it is still not implemented yet. 

#223201
May 21, 2020 13:51
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.