Find: Developer indexes with SSL (https)

Vote:
 

Our developers are in need of a EPiServer Find index of their own when developing, but as I see from my developer index service type (at find.episerver.com) it does not support (https) SSL. We need all our traffic to be SSL supported even when developing as we use real data (also clients may have business secrets they don't won't to expose before launch data). Is it possible to obtain developer indexes which support SSL? With real or simulated real data in development it is very important that all traffic is encrypted between developer machine and EPiServer Find in the cloud!

#133169
Aug 27, 2015 9:21
Vote:
 

Just change the URL from http:// to https:// in the config you get from the Find site.

#144584
Feb 15, 2016 21:39
Vote:
 
Hi , Some how Epi-Find Tab is not displaying in my cms. I have added Shell tab properly. In Admin mode I can see Epi find indexing job. Please help me. Thanks Abhishek
#178925
May 26, 2017 13:55
Vote:
 

Check that you are a part of SearchAdmins role.

<virtualRoles addClaims="true">
			<providers>
				<add name="SearchAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="SomeGroupName1,SomeGroupName2" mode="Any" />
#178926
May 26, 2017 13:59
Vote:
 

Hi 

I am realy new epi find.  Site is in Windows Authentication Mode.

I am user from Administartor group. So I have added above tab in framework file with WebAdmin and administartor. But doesn't work. Could you please sugest asap, what is missing? 

Thanks

Abhishek

#178929
May 26, 2017 15:42
Vote:
 

Do you have this somewhere inside protectedModules?

<episerver.shell>
		<protectedModules rootPath="~/EPiServer/">
			<add name="Find">
				<assemblies>
					<add assembly="EPiServer.Find.Framework" />
					<add assembly="EPiServer.Find.UI" />
					<add assembly="EPiServer.Find.Blocks" />
					<add assembly="EPiServer.Find.Cms" />
				</assemblies>
			</add>
		</protectedModules>
#178931
May 26, 2017 15:51
Vote:
 

Hi Johan,

Thanks for your contnious support. Yes I did all settings. But not difference.

One thing I have noticed, in Admin mode when I try to access "Search Configuartion" it asking me credentials. So here I am not sure as I am administrator still it asking.

This is CMS 9 and Epi-Find 11.

Please suggest if you have any doubt?

Thanks

Abhishek

#178932
May 26, 2017 16:28
Vote:
 

Then it's probably your configured dev/demo index that's expired. Try aquire a new one from find.episerver.com and change <episerver.find serviceUrl="" defaultIndex="" /> to what your are given.

#178933
May 26, 2017 16:34
Vote:
 

Ok! But on my Epifind login it is not showing any expiration messsage?

How to find that?

Thanks

Abhishek

#178934
May 26, 2017 16:37
Vote:
 

One more thing remain to share , that from Admin mode Index rebuild working fine.

Thanks

Abhi

#178935
May 26, 2017 16:39
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.