log4net dependency

Vote:
 

Hi all,

Is there a specific reason why the EPiServer Framework NuGet package has a strict dependency on log4net.1.2.10?

This prevents other packages, that request a higher version, from installing in your project, which is becoming quite a problem.

 

Best,

Jeroen

#86127
May 14, 2014 11:56
Vote:
 

The reason is that the higher version of log4net is signed with a different key, see https://www.google.se/search?q=log4net+publickey&oq=log4net+publickey

#86144
May 14, 2014 16:05
Vote:
 

Install other packages using `-ignoredependencies` :) But yes - I would suggest to switch to some other logging framework - let's say Common.Logging and give devs option to choose desired appender.

#86352
May 19, 2014 21:25
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.