EpiServer CMS Catalog UI Customization

Vote:
 

Hello,

I am in the process of upgrading EpiServer 7.5 to the latest version (Commerce 13 & CMS 11). In the old application, the product planners had a separate web utility to manage product description, images, Keywords etc., I am looking for hep to deprecate that utility and use the EpiServer CMS to perform the same tasks. 

  1. Is it possible to add extra filters to the product listing page that will allow us to filter the products based on some custom properties?
  2. when uploading images via the assets tab, can we enforce location of images? Currently the utility uploads images to For All Sites/Catalogs/Root/ProductImages/{Brand}/{Category}/{ProductCode}. So can we enforce this when uploading via CMS?  I was thinking to listen onpublish event and move the images to the right location, is it the right way day to do it? or is there a better alternative?

Thanks,

Naveed Quadri

#227917
Sep 16, 2020 9:26
Vote:
 
  1. Unfortunately no, at least not any reasonably easy way to do it. I might look into it if time permits but that's not a promise. I don't think Commerce team will prioritize such feature, but I can file a feature request for them
  2. I'm not sure I understand what you mean. It uploads to For Allsites for me
#228265
Sep 22, 2020 9:06
Vote:
 

Thanks Quan Mai.

For Point 2:

Currently, In CMS when we are adding assets the user can select assets from different locations for the same catalog product. I wanted to put a restriction so that the assets can be added from a predefined location only. For example, product belonging to brand 'ABC' and category 'XYZ' and code is 'TEST', then the assets should be saved at 'All Sites/Catalogs/Root/ProductImages/ABC/XYZ/TEST'. Since I couldn't find a way to put that restriction, I was thinking of moving the images to the 'correct' location. This will help us in keeping the images organized. 

Hope I am clear now. Anyways, since point 1 cannot be done, I might not be needing this anyway.

#228370
Sep 24, 2020 10:34
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.