Add line item to order

Vote:
 

When we try to add a new lineitem to an order in the administration view we get an error and cannot add any products. Does anyone have a solution for this ? Or is this functionallity not finish for the new orderview ?

no segments* file found in Lucene.Net.Store.Azure.AzureDirectory lockFactory=: files:

The site is using episerver find.

and it is also not possible to add payment method, the dropdown is empty

Thanks

#230741
Edited, Nov 12, 2020 10:24
Vote:
 

It looks like your search functionality is broken. What search provider are you using? Is it LuceneAzureSearchProvider?

#230742
Nov 12, 2020 10:26
Vote:
 

Thanks for your quick answer. Found one problem, SearchProviders defaultProvider had changed automatically when we updated to the latest epi packages yesterday. 

So I have changed the default provider, and the error is gone. But I do not get any results when I type in the product variant text box. 

As long as the error is gone I can research further. Thanks again

#230744
Nov 12, 2020 10:51
Vote:
 

You probably want to rebuild your index to be able to search for SKU. 

#230746
Nov 12, 2020 11:11
Vote:
 

Correct, thanks. But one last thing, do we have to set this (search.config) up in both the cms and the commerce project ? And is it possible to create Mediachase.Search.Release.config to use different index for dev and prod ?

#230747
Nov 12, 2020 11:22
Vote:
 

It depends on how you set up your site actually. Normally you want to share the index between the "cms" site and commerce manager, but you can have different indexes, or even different search providers.

Regarding the release transformation it should be possible, but I haven't tried it myself

#230748
Nov 12, 2020 11:27
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.