Content type incorrect in application (EPiServer.Core.TypeMismatchException)

Vote:
 

Hi,

Version: Commerce 11.8.5
Setup: Admin, front1, front2, front3

We had an (2, technically) incident where all the content (Products, Variants, Categories...) in Commerce reverted back to its core implementation: Castle.Proxies.ProductContentProxy (etc) instead of our custom implementation, giving us EPiServer.Core.TypeMismatchException all over the place. Perhaps notable is that only Admin & Front3 seems to have been affected.

This was not preceeded by an IIS reset, App Pool Recycle or anything else that I can find in the System/Application logs; everything looks fine as far as I can see (checked around the time of the first occurance of the error +- a couple of hours.

The database looked fine which made us perform an IIS RESET which fixed the issue, however a lot of damage was already done by the time we realized the issue. 

I'm just wondering if this is something known, our best guess is that it might be a bug in EpiServer. I haven't been able to find any details on issues that matches our issue on the forum, or anywhere else for that matter.

Timeline:
Deployed 11.8.5: 2018-08-15
...
First occurace on front3: 2018-09-08 23:37
Fixing IIS reset: 2018-09-09 22:20
...
First occurance on admin: 2018-09-12 13:33
Fixing IIS reset: 2018-09-13 09:21

These are the only occurances.


Any ideas are appreciated.
Thanks,
Fredrik

#197147
Sep 24, 2018 19:11
Vote:
 

We had report of this incident before but we could not gather enough data to draw a conclusion. However I suggest to make content type sync setting is disabled in Commerce Manager , at least to start with

#197149
Sep 24, 2018 21:06
Vote:
 

This should be in web.config of Commerce Manager 

  <episerver>
    <applicationSettings enableModelSyncCommit="false" uiUrl="~/UI/" enableScheduler="false" />
  </episerver>
#197168
Sep 25, 2018 13:47
Vote:
 

Current Commerce Manager Web.config already has basically the same settings set, with the exception of uiUrl="~/EPiServer/CMS/":

<applicationSettings httpCacheability="Public" pageValidateTemplate="false" uiShowGlobalizationUserInterface="true" uiUrl="~/EPiServer/CMS/" urlRebaseKind="ToRootRelative" enableScheduler="false" enableModelSyncCommit="false" />

#197784
Oct 12, 2018 14:16
Vote:
 

So the problem is something else...do you have any other sites, like serviceapi?

#197790
Oct 12, 2018 18:22
Vote:
 

To give an update; we didn't take any actions to solve this, but haven't seen it happen again.

#204112
May 20, 2019 10:20