Error installing Commerce Service API - 8.16

Vote:
 

Hi

I am trying to install Commerce Service API to my frontend site using nuget.

I am using this guide http://world.episerver.com/documentation/items/episerver-service-api/configuration-and-overview/setting-up-episerverserviceapi/

but I am getting some errors and strange ones

"install-package : Updating 'EPiServer.CMS.Core 8.10.1' to 'EPiServer.CMS.Core 9.0.1' failed. Unable to find a version of 'EPiServer.CMS.UI.Core' that is compatible with 
'EPiServer.CMS.Core 9.0.1'."

Here is the log, this is the first time i install Commerce Service API

PM> install-package Episerver.ServiceApi.Commerce
Attempting to resolve dependency 'EPiServer.ServiceApi (≥ 1.6.0)'.
Attempting to resolve dependency 'EPiServer.CMS.Core (≥ 9.0.1 && < 10.0)'.
Attempting to resolve dependency 'EPiServer.Framework (= 9.0.1)'.
Attempting to resolve dependency 'Newtonsoft.Json (≥ 5.0.8 && < 7.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.Mvc (≥ 4.0.20710.0 && < 6.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebPages (≥ 3.2.3 && < 3.3.0)'.
Attempting to resolve dependency 'Microsoft.Web.Infrastructure (≥ 1.0.0.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.Razor (≥ 3.2.3 && < 3.3.0)'.
Attempting to resolve dependency 'structuremap-signed (≥ 3.1.6.186 && < 4.0)'.
Attempting to resolve dependency 'structuremap.web-signed (≥ 3.1.6.186 && < 4.0)'.
Attempting to resolve dependency 'Castle.Windsor (≥ 3.2 && < 4.0)'.
Attempting to resolve dependency 'Castle.Core (≥ 3.3.0)'.
Attempting to resolve dependency 'Owin (≥ 1.0 && < 2.0)'.
Attempting to resolve dependency 'System.IdentityModel.Tokens.Jwt (≥ 3.0 && < 5.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi (≥ 5.1.2 && < 6.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.WebHost (≥ 5.2.3 && < 5.3.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Core (≥ 5.2.3 && < 5.3.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Client (≥ 5.2.3)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Owin (≥ 5.1.2 && < 6.0)'.
Attempting to resolve dependency 'Microsoft.Owin (≥ 2.0.2)'.
Attempting to resolve dependency 'Microsoft.Owin.Security.OAuth (≥ 2.1.0 && < 4.0)'.
Attempting to resolve dependency 'Microsoft.Owin.Security (≥ 3.0.1)'.
Attempting to resolve dependency 'Microsoft.Owin.Host.SystemWeb (≥ 2.1.0 && < 4.0)'.
Attempting to resolve dependency 'EPiServer.Commerce.Core (≥ 8.17.0 && < 9.0)'.
Attempting to resolve dependency 'Lucene.Net (≥ 3.0.3 && < 4.0)'.
Attempting to resolve dependency 'SharpZipLib (≥ 0.86.0)'.
Attempting to resolve dependency 'AuthorizeNet (≥ 1.8.2 && < 2.0)'.
Attempting to resolve dependency 'log4net (≥ 2.0.3 && < 3.0)'.
Installing 'structuremap-signed 3.1.6.186'.
Successfully installed 'structuremap-signed 3.1.6.186'.
Installing 'structuremap.web-signed 3.1.6.186'.
Successfully installed 'structuremap.web-signed 3.1.6.186'.
Installing 'EPiServer.Framework 9.0.1'.
You are downloading EPiServer.Framework from EPiServer AB, the license agreement to which is available at http://www.episerver.com/eula/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'EPiServer.Framework 9.0.1'.
Installing 'EPiServer.CMS.Core 9.0.1'.
You are downloading EPiServer.CMS.Core from EPiServer AB, the license agreement to which is available at http://www.episerver.com/eula/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'EPiServer.CMS.Core 9.0.1'.
Installing 'System.IdentityModel.Tokens.Jwt 3.0.0'.
You are downloading System.IdentityModel.Tokens.Jwt from Microsoft, the license agreement to which is available at http://go.microsoft.com/fwlink/?LinkId=301992. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'System.IdentityModel.Tokens.Jwt 3.0.0'.
Installing 'EPiServer.ServiceApi 1.6.0'.
You are downloading EPiServer.ServiceApi from EPiServer AB, the license agreement to which is available at http://www.episerver.com/eula/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'EPiServer.ServiceApi 1.6.0'.
Installing 'log4net 2.0.3'.
Successfully installed 'log4net 2.0.3'.
Installing 'EPiServer.Commerce.Core 8.17.0'.
You are downloading EPiServer.Commerce.Core from EPiServer AB, the license agreement to which is available at http://www.episerver.com/eula/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'EPiServer.Commerce.Core 8.17.0'.
Installing 'EPiServer.ServiceApi.Commerce 1.6.0'.
You are downloading EPiServer.ServiceApi.Commerce from EPiServer AB, the license agreement to which is available at http://www.episerver.com/eula/. Check the package for additional dependencies, which may come with their own license agreement(s). Your use of the package and dependencies constitutes your acceptance of their license agreements. If you do not accept the license agreement(s), then delete the relevant components from your device.
Successfully installed 'EPiServer.ServiceApi.Commerce 1.6.0'.
Install failed. Rolling back...
install-package : Updating 'EPiServer.CMS.Core 8.10.1' to 'EPiServer.CMS.Core 9.0.1' failed. Unable to find a version of 'EPiServer.CMS.UI.Core' that is compatible with
'EPiServer.CMS.Core 9.0.1'.
At line:1 char:1
+ install-package Episerver.ServiceApi.Commerce
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

#139000
Sep 24, 2015 16:36
Vote:
 

Hi,

Which version of Visual Studio are you using? I suppose it is VS2013? We saw an issue with Nuget 2.x (comes with VS2013) that sometimes it fails to discover the correct version.

Can you try it with VS2015 to see if it works for you?

Regards,

/Q

#139002
Sep 24, 2015 16:55
Vote:
 

We have collected information and workarounds for this type of issues in this article.

#139012
Sep 24, 2015 21:00
Vote:
 

Hi Quan

We are using VS 2013, I will try with VS2015.

@magnus: Thanks for the link, I will check it out, and see if its help me, I dont want to install VS2015, så I will check if there is another workaround...

Thanks

#139228
Sep 27, 2015 21:17
Vote:
 

Hi

I Manage to start the nuget installation from VS2013, but now I get another error:

Attempting to resolve dependency 'EPiServer.ServiceApi (≥ 1.6.0)'.
Attempting to resolve dependency 'EPiServer.CMS.Core (≥ 9.0.1 && < 10.0)'.
Attempting to resolve dependency 'EPiServer.Framework (= 9.0.3)'.
Attempting to resolve dependency 'Newtonsoft.Json (≥ 5.0.8 && < 7.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.Mvc (≥ 4.0.20710.0 && < 6.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebPages (≥ 2.0.20710.0 && < 2.1)'.
Attempting to resolve dependency 'Microsoft.Web.Infrastructure (≥ 1.0.0.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.Razor (≥ 2.0.20710.0 && < 2.1)'.
Attempting to resolve dependency 'structuremap-signed (≥ 3.1.6.186 && < 4.0)'.
Attempting to resolve dependency 'structuremap.web-signed (≥ 3.1.6.186 && < 4.0)'.
Attempting to resolve dependency 'Castle.Windsor (≥ 3.2 && < 4.0)'.
Attempting to resolve dependency 'Castle.Core (≥ 3.2.0)'.
Attempting to resolve dependency 'Owin (≥ 1.0 && < 2.0)'.
Attempting to resolve dependency 'System.IdentityModel.Tokens.Jwt (≥ 3.0 && < 5.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi (≥ 5.1.2 && < 6.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.WebHost (≥ 5.2.3 && < 5.3.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Core (≥ 5.2.3 && < 5.3.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Client (≥ 5.2.3)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Owin (≥ 5.1.2 && < 6.0)'.
Attempting to resolve dependency 'Microsoft.AspNet.WebApi.Core (≥ 5.1.2 && < 5.2.0)'.
Updating 'Microsoft.AspNet.WebApi.Core 5.2.3' to 'Microsoft.AspNet.WebApi.Core 5.1.2' failed. Unable to find a version of 'Microsoft.AspNet.WebApi.WebHost' that is compatible with 'Microsoft.AspNet.WebApi.Core 5.1.2'.

Any ideas?

Thanks

#139306
Sep 29, 2015 14:59
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.