Catalogs.js not found error after upgrade to 8.11

Vote:
 

Hi

After upgrade to commerce 8.11 the commerce catalogue is missing and i get this error

404

http://localhost/secretpath/manage/Shell/8.0.2.0/ClientResources/epi-ecf-ui/component/Catalogs.js

anybody have idea?

 

//pawel

#120858
Apr 27, 2015 11:25
Vote:
 

It's quite clear that you have a faulty module registration. It should belong to Commerce module instead. What do you have in your protectedModules section in web.config?

Regards.

/Q

#120864
Apr 27, 2015 12:00
Vote:
 

thank you for your reply

<protectedModules rootPath="~/SPSM/manage/">
<add name="AddOn.Favorites"></add>
<add name="EPiServerCommon" resourcePath="~/EPiServerCommon/">
<assemblies>
<add assembly="EPiServer.Common.Gadgets" />
<add assembly="EPiServer.Common.Criteria" />
</assemblies>
</add>
<add name="Commerce">
<assemblies>
<add assembly="EPiServer.Business.Commerce" />
<add assembly="EPiServer.Commerce.UI" />
</assemblies>
</add>
<add name="EPiServer.Commerce.Shell" resourcePath="{rootpath}/Commerce/Shell" />
<add name="Shell" />
<add name="CMS" />
<add name="Find">
<assemblies>
<add assembly="EPiServer.Find.Framework" />
<add assembly="EPiServer.Find.UI" />
<add assembly="EPiServer.Find.Cms" />
</assemblies>
</add>
</protectedModules>

#120865
Apr 27, 2015 12:15
Vote:
 

Have you run the Move-EPiServerProtectedModules cmdlet in the package manager console?

#120868
Apr 27, 2015 13:18
Vote:
 

No, i haven´t should i?

#120869
Apr 27, 2015 13:27
Vote:
 

Yes. It has been around for a long time but since Commerce 8.11 it is a requirement. There is a note in the package readme but maybe it didn't pop up as it should.

#120870
Apr 27, 2015 13:29
Vote:
 

ok, but now im getting other error

Unable to find a module by assembly 'EPiServer.Commerce.AddOns.Manager, Version=2.0.926.0, Culture=neutral, PublicKeyToken=null'

Parameter name: moduleAssembly

i can see it is located under \modules\_protected\EPiServer.Commerce.AddOns.Manager

but somehow is not getting loaded.. did i miss something?

#120877
Apr 27, 2015 14:33
Vote:
 

It could be an assembly binding issue that is hidden. Anyway, it looks like you still have the old site-owner addon. Please try to install the EPiServer.Commerce.UI.ManagerIntegration nuget package and see if that works. 

#120879
Apr 27, 2015 14:43
Vote:
 

ok i got different error now after running managerintegration

Unable to find a module by assembly 'EPiServer.Commerce.Shell.ManagerIntegration, Version=8.11.4.656, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' Parameter name: moduleAssembly

same same but different :S

#120883
Apr 27, 2015 15:53
Vote:
 

Another customer had same issue with EPiServer.Commerce.Shell.ManagerIntegration and the solution was to run Move-EPiServerProtectedModules

Regards.

/Q

#120884
Apr 27, 2015 15:55
Vote:
 

no lyck..


I have run the Move-EPiServerProtectedModules

it added the line i web.config and also deleted the modules folder from appdata 

still getting this error when trying to log in to edti mode

#120899
Apr 27, 2015 17:59
Vote:
 

where should this file be located? 

I have it in my bin already, when i delete it from my bin i can enter online center but can´t do anything and get 
"NetworkError: 404 File not found - http://spsm.local/hittalaromedel/SPSM/manage/Shell/8.1.0.0/ClientResources/epi-ecf-ui/component/Catalogs.js"

#120900
Apr 27, 2015 18:07
Vote:
 

The EPiServer.Commerce.AddOns.Manager file is no longer needed. It is replaced by the EPiServer.Commerce.Shell.ManagerIntegration which should be in your bin-folder after you installed the package and recompiled. You should also have another entry in your protectedModules config. How does your virtual path provider configuration look (section episerver.framework / EPiServerFramework.config)?

#120904
Apr 27, 2015 19:51
Vote:
 

aha ok, well what happends when i install this package is im getting the error:

"Unable to find a module by assembly 'EPiServer.Commerce.Shell.ManagerIntegration, Version=8.11.4.656"

Which entrys should i have in my modules config and EPiServerFramework.config?

Maybe thats the missing part

#120905
Apr 27, 2015 20:58
Vote:
 

I think your protectedModules section looked correct, but you should have another entry now that you installed the ManagerIntegrationPackage:

<add name="EPiServer.Commerce.Shell.ManagerIntegration" resourcePath="{rootpath}/Commerce/Manager" />

Your virtual path configuration shouldn't contain any references to commerce, but something similar to:

<add name="ProtectedAddons" virtualPath="~/EPiServer/" physicalPath="modules\_protected" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />

Note: The virtualPath of the VPP should match what you have as rootPath for protectedModules.

#120911
Edited, Apr 28, 2015 7:15
Vote:
 

Thanks!

That helped alot.

add name="ProtectedAddons" virtualPath="~/EPiServer/" physicalPath="modules\_protected" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" was not quite right in my solution... physicalPath="[appdata]\_protected" after changing it to physicalPath="modules\_protected" ;it works better!

#120919
Apr 28, 2015 9:29
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.