Disabling the Performance gadget on Dashboard->Home

Vote:
 

Hi All,

 

I have a Episerver Commerce 1 web site. When you log in you're automatically redirected to the Dashboard -> Home page, which contains the following default gadgets: News & Announcements, Help, summary and Performance.

The performance gadget is taking a long time gathering data, which halts the loading of the dashboard and the commerce site. Is it possible to programmatically disable one or more of the default gadgets for all users?

There is no <episerver.shell> in the web.config, hence (I'm guessing) the default gadgets. Is this necessary to disable default gadgets?

Thanks in advance!

/Anders

 

#85613
Apr 30, 2014 12:04
Vote:
 

Hi,

Just to clarify thing. You're mentioning Commerce Manager site, right?

/Q

#85625
Edited, Apr 30, 2014 16:11
Vote:
 

Sorry, yes it's a Commerce Manager site based on Commerce v1 and we're using it in combination with an EpiServer 6 site.

 

I've tried overriding the default dashboard layout with:

  <episerver.shell>
    <dashboard>
      <templates>
        <add forRoles="Administrators, OtherRole, Everyone">
           
        </add>
      </templates>
    </dashboard>
  </episerver.shell>

But that doesn't seem to override the default dashboard layout for new users and the documentation is kind of sketchy on that. 

Also, for existing users who've already had their dashboard layout saved in DDS on first login, is there really no other way to alter that than through the hack of using the (unofficial) DDS Explorer Gadget to delete old layouts?

Thanks :)

#85647
May 01, 2014 10:11
Vote:
 

Hi,

Unfortunately EPiServer Shell has no power here. I believe each gadget in Commerce Manager has a "close" button on the top right. Do you try to click on here? (which will remove the gadget, although I'm not sure the settings will be stored for next session). I'll come back when I get my Commerce site up and running.

/Q

#85648
May 01, 2014 12:13
Vote:
 

True, you could in theory close the Performance gadget manually, but that would have to be done by all existing users which is a bit bothersome :)

But the main problem we're having is the fact that the site contains so many transactions and sales, that the Performance gadget causes a timeout exception analyzing these before the dashboard area is rendered, effectively preventing the user from removing the gadget window from the dashboard, by pressing the close button.

This is why I was searching for an alternate route via code, to remove a gadget from Commerce Manager dashboard but it doesn't seem to exist..? :)

#85649
Edited, May 01, 2014 12:22
Vote:
 

Hey there.

The settings for catalog gadget is per user, which means there is no "turn off" button for it. But you can do this trick:

Go to this folder:

<YourCommerceManagerSitePath>\eCommerceFramework\5.2\Shared\Apps\Dashboard\Modules

Edit the PerformanceModule.ascx, and change the property AutoEventWriteup event to false. Save the file and retry.

This will practically disable the performance gadget. It will load nothing at start.

Hope this helps.

/Q

 

 

#85726
May 02, 2014 15:00
Vote:
 

Hi,

 

Another solution is to set the Path to the Performance gadget control to empty. This will hide the gadget from Dashboard.

 

Let's open the Performance.xml file, which is located at Apps\Dashboard\Config\Controls\Configs, and update the Path property to empty string, then save the file and reload the page.

#85779
May 05, 2014 16:52
Vote:
 

Hi guys,

thanks a bunch. I'm not back on that project until friday where I'll try your suggestions out and let you you know how it works out.

But I really appreciate the help!

/Anders

#85799
May 06, 2014 9:21
Vote:
 

I went with the path change to the Perfomance gadget config file in Perfomance.xml and it worked like a charm!

Did not try the change to the Performance user control but I'm sure it would have worked as well.

Thanks a lot, both of you. I would suggest adding this to the online documentation for the commerce framework but I'm guessing this is legacy code now that the new Commerce Manager is out :)

/Anders

#86121
May 14, 2014 11:17
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.